VASL multiplayer online issues

I had updated to v3.6.2 earlier today (or maybe late yesterday?) when I saw that a new version was released.

When I check now it states that “Your version of Vassal is current”. I didn’t get a chance to test the issue tonight (busy doing other things), but can check with one of my gaming buddies tomorrow and see if we get the same issue as in 3.6.1. As I noted upthread, we did NOT get the issue in the 3.6.2-SNAPSHOT version that you had us try…

3.6.1, 3.6.2, and the shapshot you tried all have the same code for connecting to our site to checking for the current version and send bug reports. You’ll get the same result with all three if you try them all in the same sitting.

I suspect there’s something odd going on with your machine, your local network, or your ISP. How are you connecting to the internet? What ISP are you using?

Verizon FIOS Gigabit, so not a bandwidth issue. But several reasons why I would question that is the issue:

  1. There were three of us that all experienced the issue. One in Texas, one in Virginia (me), and one in Vermont. We definitely all don’t use Verizon and we all experienced the exact same issue (we were in Discord discussing what we were seeing).

  2. The guy in Vermont and I recreated the issue on an entirely separate day when you asked for the log file. We also tried it on different maps to make sure it wasn’t a ‘saved file’ issue. So if an ISP thing, it would have had to been something that lasted on both our services across several days. Not impossible, but just not likely, IMO.

  3. When the guy in Texas and I tested the SNAPSHOT version, everything worked fine. This was within 24 hours of the test above (#2). If ISP issue, /could/ have been resolved in that window… but we’re starting to stack lots of probabilities here…

  4. Prior to the update to 3.6.1, we never had this issue and were playing close to 1-2 times/week. So was definitely something that /seemed/ to coincide with that release.

I kind of want to go back to 3.5.8 and see if we get the issue again (we should not, as that is what we had been using). BUT, whatever you did in 3.6.2 seems to have fixed the issue … so I’m also inclined to say “Let’s assume it has been fixed and /if/ it appears again, I’ll contact you (with the full logfile this time :slight_smile: ) and we’ll resolve it then.”

I wasn’t suspecting lack of bandwitdh—the version check and bug reporting use hardly any. What I do suspect is a hinky DNS server, either on your router or run by your ISP.

For clarity, which issue are you referring to here? At this point, I’m talking about the version check and bug report issue only.

You could never have an SSL cert problem with 3.5.8 because 3.5.8 used HTTP, not HTTPS. The code involved changed to use HTTPS between 3.6.0-beta1 and 3.6.0-beta2 and hasn’t changed since. The only other potentially relevant change I see in the past few months is the Java version moving from 16 to 17.0.0 in 3.6.0-beta3 and to 17.0.1 in 3.6.0-beta6. Were this a Java bug, I’d expect it to be happening widely—but I see no evidence for that on the internet.

This error (from above):

Basically, moving a stack on top of a locked marker would cause everyone else to start seeing ghost images of that moving stack. This has been resolved in v3.6.2 (tested tonight) -or- just ended up resolving itself, if it really was a DNS/ISP issue.

I’m content that v3.6.2 seems to be working fine now. If the issues reappears, we will let you know … but we’ve done about 4 tests with v3.6.2 and ALL have worked fine.

I’m not talking about that problem.

The problem I’m referring to is the SSL certificate one in your error log.

Ok, so that is the confusion here… we never noticed any issue with a ‘SSL certificate’ (in terms of affecting what we could do). Everything predicated upon the formation of the ghost images and the ‘Vassal is in an unstable state’ thereafter.

To put it another way, we never had Vassal crash on us or stop working or do something weird BEFORE the ghost images and pop up an “SSL certificate” error. Everything always started to go to ‘hell and a hand basket’ after we began seeing the ghost images (or others began seeing them, as the person who was ‘creating’ them never saw them). Makes me think the “SSL certificate error” that you are talking about /may/ have been a product of this ‘unstable state’?

For future reference (for us), what should we expect to see if there is an SSL certificate error? Is that where the pop up window comes into play (about ‘grievous error’, etc?).

side comment/summary of time line of our incidents

  1. One of us creates new room online
  2. The other two join
  3. We move a few units around, but NOT moving on top of any locked markers. No issues.
  4. One of us moves a unit on top of a locked marker. On their screen, everything looks normal. On the other two peoples’ screens, it leaves behind a red box where the counter used to be and then ghost images in every spot where it was ‘dropped’. They also get the ‘stack error’ message.
  5. They try to click on a ghost image or highlight what is in the ghost image stack. Somewhere along this time they get the ‘ghastly error’ and ‘vassal is in an unstable state’ pop-up. They mention this to the person who had moved the original unit (and still only has a single ‘image’ of it on their screen).
  6. Someone else repeats this with a different unit (moving it on top of a locked marker, etc.) and now the first moving person also gets the same ‘stack error’, ‘ghastly error’ and ‘unstable state’ messages.

It could be that the ghost images created an unstable state which created the SSL errors that you are concerned about. To us, everything always started with ghost images being created …

What you’d see are messages in the error log like the ones in this post, either when checking for a new version or trying to report a bug, and also the bug dialog will tell you that bug reporting failed.

There is no connection between the drag issue you were having before 3.6.2 and the SSL certificate error you were having at the same time.

Ahh…ok. TBH, we never even knew (appreciated that?) we had an SSL certificate issue … the only thing that we physically saw was the ghost image issue.

I’ll keep an eye out for any other issues, but 3.6.2 seems to be running smoothly the couple times we’ve used it now.

There will be some diagnostic output in 3.6.3 in the event of an SSL certificate problem, so hopefully we’ll be able to see what’s actually happening for people with this problem.

i got same issue, but read your comments i think i will solve it, thank you for sharing with us

Let them know if you see it in 3.6.3. We’ve played a couple times now with 3.6.3 and have had no issues, so hopefully you’ll experience the same.

i got same issue..

If you’re having a problem, we need a description of what you’re doing and the error log. It’s not possible to help without any information.

VASL fixed a similar issue for me, thx. The error msg: "Cannot read field “gridWidth” because “map” is null does not look like it has anything to do with the former issue (err msg remains).