Vassal 3.1.0

Hello and a Happy New Year to everybody !

I just recently joined the Forum.
I downloaded Vassal 3.1.0 from the trusted site ie: the link
posted in the Forum.
When I open zip file and double click on Vassal.bat
all I get is an error message that says:

Java Virtual Machine Launcher
COULD NOT FIND THE MAIN CLASS: VASSAL.launch.Module Manager. Program will exit.

I’ve also tried to save zip file to desktop and tried to open it from
there: I get the same error message.

I used to have Vassal on my computer 6 months ago, it was working
well, however about a month ago it stopped working so I uninstalled it.

Today I uninstalled Java , cleaned out residual programs and folders
and re-installed:
Java for Windows - Firefox/Mozilla
Recommended Version 6 Update 11 (filesize: ~ 7 MB)
Windows Vista, XP, 2000, 2003 Server
Restarted computer after install, relaunched Vassal.bat and I’m still
getting the same error message(see above).

Is there a solution to this problem?

only two simple and probably incorrect observations (but might get you by until some vguru can figure it out, or at least it will provide you some entertainment if you have a good sense of humor)…

are you trying to run a bat file that is still compressed inside a zip folder?
do you not have to extract it first then run it?

I did not even know there was a zip file for windoze - ie I thought it was an exe install, so are you sure you do not have the linux version in lieu of the windoze version? [I can not see the image once I started typing the reply so I can not go back and check]

in fact - yes - I see you have the generic version - that is a built-for-linux version I believe? and since you are using winzip I presume you are trying to use the linux generic under windoze?

Thus spake “IrishBouzouki”:

The batch file in the generic archive should work on Windows—I haven’t
checked it recently, so if it doesn’t, that’s a bug.

However, the preferred install method is using the Windows installer. Try


Messages mailing list …

Post generated using Mail2Forum (

Should the bat file work from inside a zip folder though? Pretty sure I have made this mistake with exe’s and had it fail to work as expected. Not something I have tried in a while (which I guess is actually a good thing in an odd kind of way).

For one thing inside the zip the paths are all messed up right? So the bat file might not find the module launcher class where it expects it should be after extraction?

Thus spake “IrishBouzouki”:

I can’t say whether it should work form inside a zip archive. That’s not
really an expected use case.


Messages mailing list …

Post generated using Mail2Forum (

Thanks Irish Bozouki

my version is WinXP: however many thanks.
You were correct : I tried to open a .bat file in Winzip…
I extracted the file and now everything is working well.
:smiley: :smiley: :smiley:
…many thanks again