VASSAL 3.1.12 + Through the Ages module 2.46

Their are a couple of bugs. One that I’ve seen and one that I’ve heard about. The one I’ve encountered is when you choose a Leader Card from your hand & right-click to put it into play it just vanishes, the leader does not appear on the Civilization panel, and the Civil Actions on the government card does not decrease by 1 civil action. I hear there is also a problem of some kind with government cards, but I have not encountered them because I stopped playing after I had the leader problem. Reading the VASSAL forum, all is ok with VASSAL 3.1.9 and TtA 2,46. Ver 3.1.10 and beyond the leader problem occurs.TtA 2.46 is most recent module. Any ideas for a solution?

Thanks for your time.

I can confirm the problem with the government cards using VASSAL 3.1.12 and TtA 2.46. It is the same behaviour as with the leader cards (which I can also confirm).

If you try to play them from your hand, they disappear and no outcome is displayed in your Civilization card nor in the message log.

I’m giving VASSAL 3.1.0 a try, just to see if this does not happen.

Thanks for any feedback on this.

Thus spake “LtGoose”:

The change in behavior is due to one of the bugfixes in VASSAL 3.1.10.
Some modules relied on the buggy behavior which we fixed. We need the
the module designers for TtA (or someone) to look at the problem and
tell us what trait exactly is involved in the problem.


Messages mailing list …

Post generated using Mail2Forum (

Thus spake Joel Uckelman:

I tried troubleshooting this myself, but wasn’t successful and asked
Brent for help. Here’s what he found:

So, there you have it: The problem is with the module, not VASSAL 3.1.12.
You should contact the module designers to have them fix the problem.


Messages mailing list …

Post generated using Mail2Forum (

Thanks for the update, Joel. I’ve contacted the authors in order to point them to this thread. I suppose they will deal with it when they have some time.


The report that this module works with Vassal 3.1.9 and fails with 3.1.10 and later is completely bogus. The current version of the module fails in exactly the same way when using Vassal 3.1.9. This was never a problem with Vassal at all. Whoever made the initial report must have updated to a new version of the module at the same time as updating Vassal. When reverting to the old Vassal, they must have reverted the version of the module also.


*********** REPLY SEPARATOR ***********

On 17/11/2009 at 4:50 PM LtGoose wrote:

Messages mailing list …

Post generated using Mail2Forum (

I cannot say about Vassal 3.1.10 because I haven’t tested it. However, I have tested both 3.1.9 and 3.1.12 versions, with the same module version (the only one I have ever installed) and to me it works as described.

I don’t know if internally it’s working or not or even if it has ever worked right at all, but the fact is that I can reproduce the issue as stated in version 3.1.12 but not int 3.1.9.

What I mean is that, regarding gameplay, the effects of playing those cards seem to work as expected using the previous Vassal version, but doesn’t using the latest. I’m sure that debugging the actions you can see what it is doing and if it is failing or not. Perhaps the bugs fixed between both Vassal versions made the game module behave in such a way that players didn’t notice the bug in the module.

This is very strange. I have just installed Vassal 3.1.9 and the TTa module does not work - The leader cards still dissappear. Can you please post a log file showing it working under Vassal 3.1.9.



Messages mailing list …

Post generated using Mail2Forum (

No problem. I’ll do it tonight (I’ve got to get home).

Here you have the messages in VASSAL’s log window:

- I’ve just dealt new cards to start my turn.
- I pick a leader card to my hand.

You can find the log file here

Let me know if you need futher details.

I’ve been in touch with the module author, and he has told me the following:

So good news. Thanks to all who have taken a look at this issue. Now it’s time to enjoy the module! :wink:


Could you please ask the Author to supply details of exactly which traits where the cause of the problem? (He can email me directly on b.easton at exemail dot com dot au) I have now confirmed that the module does behave differently between Vassal 3.1.9 and 3.1.10 (I was looking at the wrong things before), but I cannot see any changes in 3.1.10 that should cause such a change. I want to make sure there aren’t any wider ramifications.


Messages mailing list …

Post generated using Mail2Forum (

I’ve asked the author what you want to know. I think he’ll either write here or email you with an answer.

Funny, looking at this after so long I couldn’t figure it out either. The thing is, unless it is an action card I want the card to be deleted. Each player has an at-start stack with layers for each leader/government on their civ board. I found it easier for each player to have their own stack (and therefore traits on that card can be specific to that player only, rather than trying to figure out who owned the card at the time and having all the different traits for everyone on each card).

So, when you play a leader or govt, it should delete the card and then send a trigger to that player’s civ board and the leader/govt stack to display the correct leader and send the correct message to the message window, etc.

I know, it sucks. :blush:

Someday I would like to go and clean it all up, but it seems such a daunting task.



I’ll use Alexander the Great for the Leader example. You can find him in the Main Map, Ancient Civil deck.

All I had to do was move the following trait down to the bottom: “Trigger Condition - When played, run this string of commands”. Then I moved the following below that: “Prototype - AgeACivil”.

That’s it. The Prototype has the CTRL-P command in it, and the Trigger command has the commands for the Global Key Commands (now above it).

For the Govts it was basically the same thing. I’ll use Monarchy as an example (Main Map, Civil deck).

I moved the two Trigger Actions: “Trigger Action - Trigger a Full revolution” and “Trigger Action - Trigger a peaceful revolution” to the bottom, and them moved the “Prototype - AgeICivil” below them.

I assume that the triggers only affect things above them now? I have to admit that I was always sketchy on the trait ordering and just played with it until it worked without really knowing why.

I figured this out by looking at the Wonders (which are incredibly similar in functionality to the leader and govt cards). Their triggers were below the global key commands that fired to the respective player’s board and selected the correct layer of the wonder at-start-stack. They worked, so I assumed it had something to do with ordering.

Anything else, please let me know.



Hi, I do not know how to contact the designer of the module. The game in 2.48 is quite stable. However, some leader effects (Michelangelo’s one less for a wonder, and Newton’s effects) seem not to work correctly. Can this be fixed in a later version?

Excellent work on the module!

You can contact the author here … file&u=141