VASSAL 3.2.10 not running any modules

I can’t run any Vassal game modules after installing Vassal 3.2.10

Computer:
Windows 8.1
Java version 6 update 45 (64 bit)

I was previously running 3.2.6 without problems

After downloading the latest versions of the GMT EFS series modules (AGC, AGS), I couldn’t open the modules because they aparently had been created in 3.2.8

I updated my Vassal to 3.2.10, but since then I can’t open any Vassal module at all - all I get to see is an endless loading symbol for a few minutes and then Vassal terminates by itself.

Any advice much appreciated

Cheers

Thomas

I’m not the most knowledgeable person to help, but jumping from 3.2.6 to 3.2.10, have you updated java?

By the way, try to provide as much information as possible, including your system specs like as seen below in my signature. Having that information will help others better figure out your problem and if need be fix it sooner.

My Java showed to be up to date.

When I checked my software, I seemed to have 2 Java installations

Java version6 update 45 (64 bit) and
Java version 7 update 51

Should get rid of the old version of java, don’t know if it will help or not but might be a good idea all the same.

Thus spake TB:

I can’t run any Vassal game modules after installing Vassal 3.2.10

Computer:
Windows 8.1
Java version 6 update 45 (64 bit)

I was previously running 3.2.6 without problems

After downloading the latest versions of the GMT EFS series modules
(AGC, AGS), I couldn’t open the modules because they aparently had been
created in 3.2.8

I updated my Vassal to 3.2.10, but since then I can’t open any Vassal
module at all - all I get to see is an endless loading symbol for a few
minutes and then Vassal terminates by itself.

Post the contents of the errorLog after you’ve run 3.2.10:

vassalengine.org/wiki/Error_Logs


J.

Thus spake TB:

My Java showed to be up to date.

When I checked my software, I seemed to have 2 Java installations

Java version6 update 45 (64 bit) and
Java version 7 update 51

This could be your problem:

vassalengine.org/wiki/VASSAL … _installed


J.

I removed all the versions of Java on my PC and re-installed Java 7 update 51.

When running java -version in a cmd window, it did not show java as being installed or available at all.

Thereafter I removed java again and re-installed it, but still the same result when I ran Java -version. I don’t understand this, I have this PC for almost a year and have used Vassal all the time, can’t understand why it suddenly stopped working.

Cheers

Thomas

Thus spake TB:

I removed all the versions of Java on my PC and re-installed Java 7
update 51.

When running java -version in a cmd window, it did not show java as
being installed or available at all.

Thereafter I removed java again and re-installed it, but still the same
result when I ran Java -version. I don’t understand this, I have this PC
for almost a year and have used Vassal all the time, can’t understand
why it suddenly stopped working.

Did you reboot between reinstalling java and unning ‘java -version’?


J.

Yes, I did.

Do I need to change any configuration settings on my PC in order to be able to use Java now?

Cheers

Thomas

Thus spake TB:

Did you reboot between reinstalling java and unning ‘java -version’?

Yes, I did.

Do I need to change any configuration settings on my PC in order to be
able to use Java now?

If you installed Java on Windows and this did not reuslt in the java
command being on your %PATH%, then the install failed. We’ve seen this
before, but we’ve never been able to determine why it happens—there
is obviously a flaw in Oracle’s installer. Usually people are able to
resolve it by reinstalling Java.


J.

Anything else I can do?

Thus spake TB:

Anything else I can do?

This might help you get the PATH set up correctly:

java.com/en/download/help/path.xml


J.

Thanks for the reference, but I’m struggling to follow the reference instructions.

My system is running Windows 8, but when I go to control panel, select System and then Advanced Settings I can’t find any environment variables that I can set or change

Thus spake TB:

Thanks for the reference, but I’m struggling to follow the reference
instructions.

My system is running Windows 8, but when I go to control panel, select
System and then Advanced Settings I can’t find any environment variables
that I can set or change

Sorry. I’m not a Windows user. I know that you need java on your PATH
before VASSAL will run, but any advice I’d give you about how to do that
on Windows is only going to come from Google. Maybe someone else can
help you with this part of your problem.


J.

OK, I made some progress, it’s not quite working yet, but maybe someone can help with this:

  1. I edited environment variables to have C:\Program Files (x86)\java\jre7\bin
  2. After that I ran “java -version” in a cmd screen and checked that java was running on my PC
  3. Then I reinstalled Vassal 3.2.10
  4. When I opened Vassal and tried to start a module, Vassal would not open the module and terminate after a few seconds.
  5. This is the content of the Vassal errorLog:

2014-01-27 11:50:41,082 [0-main] INFO VASSAL.launch.StartUp - Starting
2014-01-27 11:50:41,085 [0-main] INFO VASSAL.launch.StartUp - OS Windows 8 6.2
2014-01-27 11:50:41,085 [0-main] INFO VASSAL.launch.StartUp - Java version 1.7.0_51
2014-01-27 11:50:41,085 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.10
2014-01-27 11:50:41,119 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2014-01-27 11:50:49,846 [0-SwingWorker-pool-19977532-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module file D:\Documents\Privat\VASSAL Games\The Blitzkrieg Legend\BlitzkriegLegend_v4_25_rc3.vmod
2014-01-27 11:50:50,791 [0-SwingWorker-pool-19977532-thread-1] INFO VASSAL.launch.TilingHandler - No images to tile.
2014-01-27 11:50:50,792 [0-SwingWorker-pool-19977532-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module OCS - The Blitzkrieg legend
2014-01-27 11:50:50,800 [0-SwingWorker-pool-19977532-thread-1] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files (x86)\Java\jre7\bin\java -Xms256M -Xmx512M -DVASSAL.id=1 -DVASSAL.port=49389 -Duser.home=C:\Users\buettnet -cp lib\Vengine.jar VASSAL.launch.Player --load – D:\Documents\Privat\VASSAL Games\The Blitzkrieg Legend\BlitzkriegLegend_v4_25_rc3.vmod
2014-01-27 11:50:51,475 [1-main] INFO VASSAL.launch.StartUp - Starting
2014-01-27 11:50:51,479 [1-main] INFO VASSAL.launch.StartUp - OS Windows 8 6.2
2014-01-27 11:50:51,479 [1-main] INFO VASSAL.launch.StartUp - Java version 1.7.0_51
2014-01-27 11:50:51,480 [1-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.10
2014-01-27 11:50:51,480 [1-main] INFO VASSAL.launch.Launcher - Player
2014-01-27 11:52:11,052 [0-SwingWorker-pool-19977532-thread-2] INFO VASSAL.launch.AbstractLaunchAction - Loading module file D:\Documents\Privat\VASSAL Games\Barbarossa - EFS\BAGCN_v1.2.vmod
2014-01-27 11:52:12,785 [0-SwingWorker-pool-19977532-thread-2] INFO VASSAL.launch.TilingHandler - No images to tile.
2014-01-27 11:52:12,786 [0-SwingWorker-pool-19977532-thread-2] INFO VASSAL.launch.AbstractLaunchAction - Loading module Barbarossa: Army Group Center and North 1941
2014-01-27 11:52:12,788 [0-SwingWorker-pool-19977532-thread-2] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files (x86)\Java\jre7\bin\java -Xms256M -Xmx512M -DVASSAL.id=3 -DVASSAL.port=49413 -Duser.home=C:\Users\buettnet -cp lib\Vengine.jar VASSAL.launch.Player --load – D:\Documents\Privat\VASSAL Games\Barbarossa - EFS\BAGCN_v1.2.vmod
2014-01-27 11:52:13,486 [3-main] INFO VASSAL.launch.StartUp - Starting
2014-01-27 11:52:13,490 [3-main] INFO VASSAL.launch.StartUp - OS Windows 8 6.2
2014-01-27 11:52:13,490 [3-main] INFO VASSAL.launch.StartUp - Java version 1.7.0_51
2014-01-27 11:52:13,490 [3-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.10
2014-01-27 11:52:13,491 [3-main] INFO VASSAL.launch.Launcher - Player
2014-01-27 11:52:36,748 [0-SwingWorker-pool-19977532-thread-3] INFO VASSAL.launch.AbstractLaunchAction - Loading module file D:\Documents\Privat\VASSAL Games\Barbarossa - EFS\BAGSCN_v1.3.vmod
2014-01-27 11:52:38,312 [0-SwingWorker-pool-19977532-thread-3] INFO VASSAL.tools.io.ProcessLauncher - launching C:\Program Files (x86)\Java\jre7\bin\java -classpath lib\Vengine.jar -Xmx526M -DVASSAL.id=6 -Duser.home=C:\Users\buettnet -DVASSAL.port=49416 VASSAL.tools.image.tilecache.ZipFileImageTiler D:\Documents\Privat\VASSAL Games\Barbarossa - EFS\BAGSCN_v1.3.vmod C:\Users\buettnet\AppData\Roaming\VASSAL\tiles\cc694871bc7a4e3a73ffb35f99d591a4c4e0336c 256 256
2014-01-27 11:52:38,944 [6-main] INFO VASSAL.tools.image.tilecache.ZipFileImageTiler - Starting
2014-01-27 11:52:41,419 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - VASSAL: Problem with socket on port 49386
2014-01-27 11:52:41,419 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - java.net.SocketException: Permission denied: connect
2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.DualStackPlainSocketImpl.connect0(Native Method)
2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
2014-01-27 11:52:41,420 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.PlainSocketImpl.connect(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.SocksSocketImpl.connect(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.Socket.connect(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.Socket.connect(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.Socket.(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at java.net.Socket.(Unknown Source)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream - at VASSAL.launch.ModuleManager.main(ModuleManager.java:216)
2014-01-27 11:52:41,421 [0-main] WARN VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:54,697 [1-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_title
2014-01-27 11:52:54,697 [1-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_heading
2014-01-27 11:52:54,697 [1-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_message
2014-01-27 11:52:54,701 [1-main] ERROR VASSAL.tools.ProblemDialog -
java.net.SocketException: Permission denied: connect
at java.net.DualStackPlainSocketImpl.connect0(Native Method) ~[na:1.7.0_51]
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.PlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.SocksSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at VASSAL.launch.Launcher.(Launcher.java:123) ~[Vengine.jar:na]
at VASSAL.launch.Player.(Player.java:60) [Vengine.jar:na]
at VASSAL.launch.Player.main(Player.java:55) [Vengine.jar:na]
2014-01-27 11:54:13,799 [3-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_title
2014-01-27 11:54:13,799 [3-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_heading
2014-01-27 11:54:13,799 [3-main] ERROR VASSAL.i18n.BundleHelper - No Translation: Error.communication_error_message
2014-01-27 11:54:13,803 [3-main] ERROR VASSAL.tools.ProblemDialog -
java.net.SocketException: Permission denied: connect
at java.net.DualStackPlainSocketImpl.connect0(Native Method) ~[na:1.7.0_51]
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.PlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.SocksSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at VASSAL.launch.Launcher.(Launcher.java:123) ~[Vengine.jar:na]
at VASSAL.launch.Player.(Player.java:60) [Vengine.jar:na]
at VASSAL.launch.Player.main(Player.java:55) [Vengine.jar:na]
2014-01-27 11:54:39,243 [6-main] ERROR VASSAL.tools.image.tilecache.ZipFileImageTiler -
java.net.SocketException: Permission denied: connect
at java.net.DualStackPlainSocketImpl.connect0(Native Method) ~[na:1.7.0_51]
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[na:1.7.0_51]
at java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.PlainSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.SocksSocketImpl.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.connect(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at java.net.Socket.(Unknown Source) ~[na:1.7.0_51]
at VASSAL.tools.image.tilecache.ZipFileImageTiler.main(ZipFileImageTiler.java:136) ~[Vengine.jar:na]
2014-01-27 11:54:39,244 [6-main] INFO VASSAL.tools.image.tilecache.ZipFileImageTiler - Exiting

Thus spake TB:

2014-01-27 11:52:41,419 [0-main] WARN
VASSAL.tools.logging.LoggedOutputStream - VASSAL: Problem with socket on
port 49386
2014-01-27 11:52:41,419 [0-main] WARN
VASSAL.tools.logging.LoggedOutputStream -

2014-01-27 11:52:41,420 [0-main] WARN
VASSAL.tools.logging.LoggedOutputStream - java.net.SocketException:
Permission denied: connect

Someting is blocking connections on the lookback interface on your
machine. Do you have a local firewall running?


J.

Yes, I have a firewall in place (Comodo). This was already in place before I encountered these issues.
What exactly would I have to change in the firewall to enable Vassal to work correctly?

Kind regards

Thomas

Thus spake TB:

Someting is blocking connections on the lookback interface on your
machine. Do you have a local firewall running?

Yes, I have a firewall in place (Comodo). This was already in place
before I encountered these issues.
What exactly would I have to change in the firewall to enable Vassal to
work correctly?

You need to tell it to permit connections on the loopback device,
which should have address 127.0.0.1.


J.

OK, thank you, will try that.

Quick update:

  1. I disabled loopback filtering in my firewall software. Thereafter I was still not able to run Vassal modules.

  2. I disabled the firewall completely. Now I could start Vassal modules and run game files.

  3. I enabled the firewall again. Afterwards I was still able to open Vassal and run modules and game files. Go figure. Hope it stays that way now.

Many thanks for all the help over the last 2 days, much appreciated.

Cheers

Thomas