VASSAL has run out of memory

When running the module for Decision Games Atlantic Wall 2.5.0 with Vasal 3.2.17, I get the error saying
that Vassal has run out of memory and to increase the max heap size.

I have tried changing the max heap to everything from 512, 1024, 2048, 4096 and 11,000 and get the same message???
My system has 16 GB of ram with Windows 10.
Is this a bug with this module?
Any suggestions?


Turns out this is not an issue with Vassal or the module, since
both work perfectly fine on my laptop with Windows 7. I now
suspect the problem is with Windows 10. I have tried to run
Vassal in compatibility mode as Windows 7 and 8 but that did
not fix the problem. Maybe there is a Java issue with Windows 10?

I run with windows 10, everything works just fine.
download and reload java
download and reload VASSAL
download and reload the module ( Atlantic Wall 2.5.0 with Vassal 3.2.17)

Start a new (clean) game in Atlantic Wall 2.5.0 with Vassal 3.2.17
I have had problems with at start game files and saved game files giving errors.
Also you can try the ‘Tools’ button at the top of the screen, and refresh the counters.
I have had problems when making changes to a module older saves wont get any unit upgrades and may cause errors.


Thanks Kevin, I tried as you said but the problem is still there…
What version of Java do you run?
I have Version 8 Update 191 (build 1.8.0_191-b12) witch is a 32 bit version (I still use IE 11)


Java 1.8, 1.8.0_191-b12 x86_64
I have Windows 10 version1803(OS Build 17134.472)

Well sorry I couldn’t help, I think your problem is above my pay-grade.