vassal on High DPI devices (i.e. MS Surface)

Hi I have a Surface Pro 4 where I run vassal. Windows 10 Pro, latest jre …

Like others I had some troubles with the small icons and text, but luckily google gave me some tips:
• I created a vassal.manifest file with some arcane xml codes I found somewhere and put it next to the vassal.exe
• Edited the registry somehow (again following instructions found here: … plays-fix/)
• Also put a file in most folders in my system.
• Tweaked the font size in vassal preferences.
• Messed with vassal.exe compatability settings.

I don’t know which one of these did the trick, but eventually vassal became usable. Not only usable, it was perfect actually (aside from the tiny text on the server status panel).

So I’m posting this on the hope somebody in the same situation finds a solution and shares it here.

But with the Anniversary Update this all has stopped working, at least for me. Vassal is too small again.

I have read Dan Antonelli registry+manifest method should still work, but for me it doesn’t.

So I’m trying to use the Linux subsystem to launch vassal there… a bit convoluted I know. But I need to try at least.

Installed xming (a X server for Windows). Typed export DISPLAY=:0; apt-get install firefox. Bingo! cemoreno@surface$firefox Works flawlessly.

$apt-get install default-jre
$tar -xjvz *
$cd VASSAL-3.2.16

… no luck. Anyone has any idea how to make this work?