Vassal on Mac vs Windows

I’ve been playing some Vassal (version 3.2.17) modules on my Mac (macOS Sierra v 10.12.1) and have become used to the functionality on the Mac.
Recently, I was on my sons Window machine and tried out Vassal and noticed Vassal works a lot better on the Windows machine than it does on the Mac.

It’s just the little things, but for example (on a mac) when you draw a piece from a deck and drag it to a location on the map (deck located on the same window as the map), a rectangle extends from the deck to the piece you just drew from the deck and any current pieces on the map that falls within that rectangle becomes selected with the peace you just drew from the deck. It’s kind of a pain, you get use to just clicking on the map to deselect everything, but if you don’t, then you end up inadvertently moving all the pieces if you move your new piece again.

This doesn’t happen on the window machine - no rectangle extends from the deck to your new piece and you don’t inadvertently select a bunch of other pieces. Kind of nice.

Any way the Mac Vassal version can be updated with the same functionality as the Windows Vassal version?


Interesting, I have a Windows machine and I experience the exact problem you describe.

Maybe it’s a Java problem.
I’m using a Windows 10 machine updated with the latest java (java 8 update 121)

I tried updating the Java on my Mac (macOS Sierra v 10.12.1) to the latest java (java 8 update 121) to see if I could get the same functionality I have on my Windows 10 machine. Once I made the update, Vassal was seriously degraded on my Mac to the point I couldn’t even play a game on it. I had to revert back to Java 8 update 111 on my Mac to get Vassal working again. Still have the selection rectangle inadvertently appearing when drawing an item from a deck though.
Works great on the Windows 10 machine with java 8 updater 121, no selection rectangle appears when drawing an item from a deck.


The things you’re describing here are very likely bugs in recent versions of Java, not in VASSAL itself. As such, there’s little we can do about them. This kind of thing will cease to be an an issue once we’re no longer using Java in VASSAL 4.

I am running vassal and maptools on ubuntu 16/17 and using java 8 xx don’t know the build but ubuntu keeps it spiffy current. not one problem on any machine.

I also had similar problem on Windows 10 machine, however with java 8 update the problem ha been resolved. You should also update your java and try again. I wish for best.