Vassal stopped working

I installed some MS Windows Updates and upgraded Java to 6.21, and now when I run VASSAL, nothing happens. I can see a VASSAL process in the Task Manager, which I can kill, but it makes no difference. I double-click on VASSAL.exe, the VASSAL.exe process starts running in the Task Manager, but no window comes up. I tried uninstalling and reinstalling to no effect. What should I do?

See if running with Java 6.20 (or earlier version) makes a difference. The
windows updates shouldn’t make a difference, but the changes to java might

-----Original Message-----
From: messages-bounces@vassalengine.org
[mailto:messages-bounces@vassalengine.org] On Behalf Of fil512
Sent: Sunday, August 15, 2010 12:25 PM
To: messages@vassalengine.org
Subject: [messages] [Technical Support & Bugs] Vassal stopped working

I installed some MS Windows Updates and upgraded Java to 6.21, and now
when I run VASSAL, nothing happens. I can see a VASSAL process in the
Task Manager, which I can kill, but it makes no difference. I
double-click on VASSAL.exe, the VASSAL.exe process starts running in the
Task Manager, but no window comes up. I tried uninstalling and
reinstalling to no effect. What should I do?


Read this topic online here:
https://forum.vassalengine.org/t/vassal-stopped-working/3185/1

I just installed Java 6.21 before this problem started happening.

Hmm… I rebooted and it started working again. Must have just been local weather conditions…

Thus spake fil512:

“fil512” wrote:

I just installed Java 6.21 before this problem started happening.

Hmm… I rebooted and it started working again. Must have just been
local weather conditions…

No, this is a known problem with Java on Windows. If you do an update, you
MUST reboot before trying to run VASSAL (or any other Java program). I wish
we could detect when this has happend and show the user a warning dialog,
but the same problem which prevents VASSAL from running might also prevent
us from even showing the user a dialog reminding him to reboot.


J.