Vassal won't load modules on new computer


Yesterday I had to invest in a new Surface Pro since my old had seen better days. On the old one, Vassal ran like a charm. Was quite suprised to find Vassal wouldn’t run (or really, load modules ) on the new one, using the exact same set up. It seems to freeze or stop once the little window pops up showing the progress of the load.

I’ve spent quite a few hours trying to find a solution. So far, no go.

Old one: Surface 3. Atom, 2 GB. Win 10 (64). Java 6 update 45 (64). Vassal 3.2.17.

New one: Surface Pro. i5, 8GB. Win 10 (64). Java 6 update 45 (64). Vassal 3.2.17.

Anyone experienced anything like this before?


Have you checked the contents of the errorLog?

I’ve checked but didn’t understand what it was trying to tell me, or how to fix it. I’ll attach it to this post. Cheers. /H

Didn’t get the file previously. Here it is. /H

[attachment=0]errorLog hakhen 20 mar.txt[/attachment]

Finally got a day off from work (national holiday), and some time to breathe. Big gulps. Slowly.

Hooked up my old externa hard drive where I had saved some old Vassal modules. Turns out, I could run those without problem. And I realized, after downloading Vassal on my new machine, I only downloaded and tried to open a single game: Fields of Fire ver.1.4.

So, the problem is not in running Vassal on this machine, it is this particular module.



After opening an older version of Fields of Fire (and some other Vassal modules I had saved), I was able to open the new version of FoF, too. The one that was giving my such trouble. Go figure! Well, it’s up and running now. Don’t know why or how!


Vassal still acting strange.

To recap, I migrated to a new computer. Just a newer model of my old one, same set up, running on same version of Java. Couldn’t open Vassal modules. Noticed that my troubles seemed to concern a one one module, Fields of Fire 2nd edition.

This wasn’t quite correct. It turns out, I can’t open any module that is located on my computer. But if I try to open the exact same file from my external hard drive, it works.

Just thought I should let you know. If anyone is experiencing similar problems, save your module on an external drive and try to open it from there. Worked for me.