Zipping Mods and Extensions on a Mac

Ok, I’m new to making modules/extensions, so bear with me.

I use a Mac.

My understanding is that a .vmod and .vmdx are simply zipped folders. When I changed the file ending of an extension to .zip, I was able to unzip it with no problems. Then I tried to zip it back, with no changes to the files in the folder. I removed the .zip file ending and changed it to a .vmdx again.

When I load the game (in this case, 18xx), the extension is no longer recognized.

My only guess is that Macs might Zip files differently from Windows.

So, I downloaded a shareware app to zip it again – I set the preferences to make the new Zip file as compatible as possible. Still no luck.

Any ideas?

Or am I doing something completely wrong?

[Unzipping and then Rezipping a module or extension. Doesn’t work.

There may be some subtle differences in what is done with zipping and
unzipping, but I haven’t investigated them. Probably the best tool to
use if you really want to do this is the zip and unzip commands that
you get from the Terminal.

Any ideas?

Or am I doing something completely wrong?

There should really be no reason that you would need to unzip a module
or extension.

Was there some particular reason you wanted to do this?

Ya, I finally figured that out.

I was typing filenames in, so the images were not being added to the module file. Thus, I thought I had to manually put the images into the images folder inside the zip file.

I discovered that using “select” will add the image to the module file automatically.