3.4.11 add a deck and a piece, setup stops working

When a major update of mine introduced some bugs that I couldn’t figure out, I went back to a version that worked, and tried to find the source of the problem.

I added a deck and a piece to the working module, that’s all. No other changes, I compared the buildfiles in Notepad++ to check.

Adding the deck and simple piece to a map completely unused in setup prevents a whole setup process from working properly. I have absolutely no idea how that could happen. Can anyone glean anything from these lines, which are the ONLY things different between a functioning and a non-functioning module?

<VASSAL.launch.BasicModule VassalVersion=“3.4.11” description=“Logistics by Splotter Spellen” name=“Roads & Boats” nextPieceSlotId=“1497” version=“0.1.8”>


<VASSAL.launch.BasicModule VassalVersion=“3.4.11” description=“Logistics by Splotter Spellen” name=“Roads & Boats” nextPieceSlotId=“1526” version=“0.2.0”>

and the latter version includes

    <VASSAL.build.module.map.DrawPile allowMultiple="true" allowSelect="true" canSave="false" color="0,0,0" countExpressions="" draw="false" drawFaceUp="true" emptyHotkey="" expressionCounting="false" faceDown="Never" faceDownFormat="" height="500" hotkeyOnEmpty="false" maxStack="1" name="polders" reshufflable="false" reshuffleCommand="" reshuffleHotkey="" reshuffleMessage="" reshuffleTarget="" restrictExpression="" restrictOption="false" reverseCommand="Reverse" reverseFormat="" reverseHotkey="" reversible="false" selectDisplayProperty="$BasicName$" selectSortProperty="" shuffle="Always" shuffleCommand="Shuffle" shuffleFormat="" shuffleHotkey="" width="500" x="2303" y="817">
        <VASSAL.build.widget.CardSlot entryName="polder" gpid="1497" height="0" width="0">+/null/prototype;noriver	prototype;tile\	prototype;polder\\	emb2;Activate;128;;;128;;;128;;;;1;false;0;0;polder1flood.png,polder1x4.png;+(flooded),;false;polder;;;false;;1;1;true;65,130;;\\\	piece;;;;polder/	\	\\	1\\\	null;0;0;1497;0</VASSAL.build.widget.CardSlot>

while the former does not.

I know there are prototypes there which reference other data, but none of is even remotely related to the buggy behaviour adding this deck and piece has caused. Is it something to do with that gpid?

I’m completely stumped, and consequently unable to add anything to my module in development. Please help!

Further testing confirms that deleting the deck makes the module work again. Adding an at-start stack with one piece in it doesn’t break anything. Adding a different deck with one piece does. Have I hit a deck cap?

Seems like a return to deck trait pointing to deck “40” in the buildfile changes destination upon adding a deck to the module. Still deck “40” in the buildfile, but switches from DeckName “shuffle” to DeckName “prayer” in the module editor. Seems like a bug to me.

At the top of my mind I think I noticed something similar: when you add new decks to a module all return to decks (pointing to decks on the same map where the deck was added, I guess) need to be reconfigured.

Not even the same map!

A prototype for pieces on one map got messed up by adding a deck to another map.