3.5.3 Search finds items in attached prototypes

I’m not sure if this is intended behavior or not, but it seems odd to me:

I was just using 3.5.3 to search for a Named Key Command that exists in a prototype; the search stopped on every piece that contained that prototype, not just the prototype itself!

I suppose that could be useful, but I would at least like an option to disable that behavior, if possible. (FYI, this is with “Match key commands” enabled; the other check boxes don’t seem to affect this behavior.)

Yes, I’ve noticed this. I think it happens with more general searches too, based on my experience.

This is tracker item 14155, and has been fixed “I hope” for 3.5.4.


Try a recent build, e.g., VASSAL-3.5.4-SNAPSHOT-cb4f850e2: vassalengine.org/~uckelman/tmp/

Just tried the above snapshot, and the problem is still there. For my particular example, you can use any recent version of the Terraforming Mars module, and search for the key command “PlusOneGreen”–this should only find 4 hits: the ScorePlusOne and playedGlobalUpdate (which isn’t actually used, just hasn’t been deleted yet) prototypes plus the UNMI card (in the Corporations deck–which should just reference the ScorePlusOne prototype, instead!), where PlusOneGreen is issued as a GKC, and the Green TM piece (in the Green TM At-Start Stack on the Main Map), where the command is processed. Instead, it finds every piece that uses the ScorePlusOne prototype, in addition.

OH! It’s somehow expanding prototypes during the search I guess. That is not the bug I fixed, so I guess this is a new bug, oh boy!

THAT bug now tracked as 14219 – vassalengine.org/tracker/sho … i?id=14219


jrwatts - I think I have fixed the problem - could you try this build here:

github.com/vassalengine/vassal/ … /664980920

Yep, that looks like it fixed it (and also showed me the module was using the command I was looking for in a couple of additional places…LOL).

I’m finding there are some situations where it would be useful for the search to expand the prototypes, after all. Could this be added as an option in the Advanced Search window?