3.6.14 is messed up, why do you have to update Vassal every two minutes?

I get a windows message that my computer won’t run the new Vassal, then it turns out I have to install 64-bit 86x or something. Why do you guys put us through this every two days or so?

Can you be more specific about the problem? Based on what you’ve said, my best guess is that you first tried installing a Windows build for the wrong CPU architecture, but I can only guess without more details about what you downloaded and what messages you saw.

We don’t. No one is forcing you to upgrade.

However, if you want support, the very first thing you’ll be advised to do is to try the current version. The reason that we support only the current version is the same reason that we release new versions often:

There is limited attention available for support.

We want to use that attention for helping with problems which have not already been solved, and as efficiently as we can. By doing frequent releases, we are stopping the flow of bug reports for bugs we have fixed. By doing smaller releases, we make it easier for users to help us pinpoint when bugs were introduced. Both of these things help us focus our support efforts where they will do the most good.

1 Like

Personally, I consider us blessed that we have developers that continue to devote their own time to fixing bugs and adding functionality.

We get better service for this FREE product, than for software that costs 50 to several hundred dollars.

8 Likes

Ditto Korval and kudos to all the fine folks who keep this thing going.

No problems with 3.6.14 at this end. None whatsoever.

Thanks to you all!

2 Likes

All good, I just had to Reinstall 3.6.14 and then reinstall all the game modules.Thanks

You shouldn’t need to reinstall any modules when you upgrade Vassal. What made you think you needed to?