3.7.10 .exe installers silently fail on Windows 11

I am running 3.7.9 and it works fine. Went to install 3.7.10, and the 64-bit and 32-bit .exe installers both fail silently before any window appears, regardless of permissions (tried running them both as admin also), and without any error log. Have not tried compatibility modes but may do that.

OS: Windows 11 Home 23H2 Build 22631.3447
Java (and JRE) version: 1.8.0_411

Hi Jura,

I am using an identical Windows build and have had no problems installing 3.7.10, as have many people. The 32 bit installer will definitely not work.

The version of any Java installation you already have is not relevant. The installer does not use Java, and installs a bundled version of Java for Vassal to use.

Not sure what to suggest next. Perhaps check your Windows system logs to see if any errors are reported their?

Also, can you try running the 3,7,9 installer again and see if it gets further? No need to overwrite your existing 3.7.9, just see if it is now failing also.


I suspect:

  • you’re trying to run the 64-bit ARM installer on a 64-bit x86 system
  • an incomplete or corrupt download
  • anti-virus program blocking the installer from running

In this order:

  • Check that you’ve downloaded VASSAL-3.7.10-windows-x86_64.exe, not VASSAL-3.7.10-windows-aarch64.exe.

  • Check that the installer you’ve downloaded has the SHA-256 hash 528fcc83c733fda9fbc5d4df7b2f87159134b4ca5ec953dd77b3712ef6d1b126. (An easy way is to upload the file to VirusTotal, as it will hash the file for you and tell you the hash.)

  • Check if your AV software is blocking or quarantining the installer.

Hi folks, thanks for all the suggestions. I’ve been running the correct 64-bit installer (triple checked actually the last few times, as I am known to do such things at times). I’ve been downloading it from the link generated on the main home page here:


A brand new download of it generates a completely different hashcode, of:


And 1 of 50 scanners VirusTotal uses, Trapmine, detects the following:

Acronis (Static ML)


I use the stock Windows AV software and it does not seem to have an issue with it (although I recall, this being a freshish Windows install, that when I installed 3.7.9 I got the “unknown source do you really want to install” pop-up, which is normal, and am not even reaching this stage with this version). There is nothing in the Windows Defender logs and it is not touching the installer.

I’ll try 3.7.9 again and confirm that works (after I download it again), but looks like what I am getting for 3.7.10 might be corrupted/infected with something that is rarely picked up by AV?


3.7.9 installer works fine.

You’re getting a hash mismatch because I accidentally uploaded the wrong build, which I hadn’t realized until just now. For 3.7.10, we upgraded Java from 21 to 22 for every release package which has Java bundled with it, except for 32-bit Windows, for which there is no Java 22. The consequence of this which is relevant is that I had to make some changes to our build process to accommodate building for 32-bit Windows, and this resulted in my doing several builds of all the packages. What I did accidentally was publish the second to last build instead of the last one—which is what the hashes were computed against. I’ll fix that shortly. Thanks for checking the hash of your installer.

However, the hash of your installer matches the one I actually uploaded, so it’s unlikely to be truncated or corrupt, and you’ve confirmed that you have the correct installer for your architecture.

What VirusTotal is showing for AV detections is a false positive and normal for Windows packages of releases since 3.7.0. I speculate that the false positives we see are due to a workaround for a Java bug that involves patching the JDK, and we’ll stop seeing them once there’s a Java release we can bundle which doesn’t require the workaround.

I think I will do a 3.7.11 release so that the current packages are the ones I intended; we can continue troubleshooting after I’ve done that.

Thanks Joel. Just for kicks I tried compatibility mode and no joy. I also checked to see if there was any process showing up in Task Manager at all and could not see one - I simply get the hourglass for a second or two and then nothing. FWIW 3.7.10 works great on my ancient 64-bit Surface Pro 3 running Windows 11 (but needless to say VASL is not quite as fast and needed some major heap tuning). I’ll keep an eye out for 3.7.11 and try it.

Compatibility mode isn’t relevant. It won’t help.

Please try this 3.7.11 test build. Are you able to install that?

Nope, exact same issue. Still nothing in Defender logs so pretty sure it is not antivirus-related, unless it is memory protection or something going on that is not being logged.

I’ve also got App Control turned off on my PC so it’s not that. Interestingly it is on on the Surface Pro, where the installer works. Can’t turn it back on on my PC without reinstalling Windows, so don’t really feel like doing that… I might try unplugging and plugging it back in though. :wink:

What happens if you try to run that test installer from the command line? Are there any error messages printed?

“Access is denied”

Now I am wondering if my App Control is borked.

Wait, did you unzip the 3.7.11 test build first? I forgot to mention that the test build downloads are ZIP archives.

Oh yeah, it was unzipped. Always.

Message was from .exe on CL

Hah! If I run it from Command Line after running cmd as administrator, it works. But it does not work if I try to run the installer as administrator (or normally) via Explorer.

Putting my reply to your note below here as apparently I have reached the daily reply limit for the forums: “Yeah, I only know enough to be dangerous also. It seems like something is borked with them for sure. Not sure why the older installers don’t have the same issue though, they are all in the exact same folder and downloaded in the exact same manner. Weird.”

Also, tempted to install Cygwin. Thanks for all your help with something this silly (whatever it is).

You’re having some kind of permissions problem, in that case. I’m not that familiar with Windows, so I don’t know what else to advise. Maybe somebody else can help from here?

I have an identical Windows build and RAM to the OP and also use default Windows Security. Vassal 3.7.10 installs however I do get a pop up Window…

…when I click on “More info”…

the “Run Anyway” option allows the installation. This also occured with previous Vassal versions. Perhaps this window is not appearing on your PC for some reason? You could try running Command Prompt as an Admin and using sfc /scannow to check your system files then reboot. Otherwise there is something in your system configuration that is not right.


Hi Darren, thanks for the suggestions. The windows are what I called App Control above I think, which I have turned off. (Can’t be turned back on without reinstalling Windows apparently). This is on on my Surface Pro 3, where the installer works fine, so it could somehow be related to this. I ran sfc and everything was fine. There is definitely something odd going on somewhere, likely to do with user and admin permissions or app permissions (but the only user on the PC is me, and has full admin permissions everywhere, i.e. Full Control). Very strange.