A Time for Trumpets memory issue

Trying to use the very newest module for ATfT. Vasssal keeps running out of memory. How do I fix this?

Go to the General tab in File > Preferences. The setting you’re looking for is “JVM maximum heap (in MB)”. The default is 512. If you’re already at 512, try 768. If that’s not enough, try 1024.

1 Like

Still won’t work


You’re changing the wrong setting. That’s the setting for the Module Manager. You need to actually open the module and go to the FIle menu, Preferences, General tab. You’ll see another setting for JVM maximum heap near the bottom of that page (each module has its own setting for this).

1 Like

Tried that. Still no joy.


Just try a larger JVM max.
If using Windows, launch the task manager first and watch the RAM usage of the game as it loads. That should give you a good idea for allocating the right size.

Did you reload the module after changing the max heap? Unlike most preferences, this one only takes effect after you reload the module.

If you’re still having a problem, post an error log from a run which failed.


I am the person who created the module.
I admit to having made a rather memory-intensive module.
On the module’s download page you should find a text file named “ATfT_Vassal_Module_v2.6_ReadMeFirst.txt” to download and read before using the module (you can also download the Module User Manual).
In this file are the explanations to properly configure the module and in particular the JVM maximum heap in the Module FIle menu (Preferences, General tab) so that it works perfectly.
All those who have encountered the “out of memory” problem have managed to configure correctly and enjoy.
You should get there too.

Hope this help

Jean Philippe

1 Like

Thanks! I have it working now!

1 Like