Adding password to player who started with Empty password?

Hi, we’ve started a PBP game using the HF4 module, but one player started without a password set for the module, so everytime we open a log file it prompts us which player to join as: our own (with matching password), or Yellow (empty password). Is there a way we can readd that player to the game with their actual password, so we don’t get this prompt?

Thankfully HF4 is not a game with any hidden info but I’m guessing if it did this would be even more of an issue.


Not sure if this will work, but try having that player: 1) load the latest logfile 2) resign their position 3) save the game 4) change their password 5) load the saved game 6) choose the Yellow side again 7) start logging and continue playing.

Cheers, I’ll have them try that - by ‘resign their position’ do you mean ‘swap to observer’ with the white-flag menu?

I would assume so…the option to change sides can be labeled differently in every module.

Alas this seems not to have worked.

Okay, further details with experiments we did on an online session today. With this logfile loaded, whenever player 1 (purple) changes sides, player 2 (yellow) is changed along with them!? Are they tied with some unique ID or something?

I’ve never seen this before, and it doesn’t happen if we start a new game. There’s something broken with this save file, somehow.

Have player 1 and player 2 compare their personal module passwords–this sounds very much like a case of them being identical (which you don’t want).

Yeah, we thought about that, but no, both players are security savvy and have strong random passwords, one has a 64-random-character password!

We’re having this issue also - according to the docs, “You can set your password in
Preferences | Personal.” Only problem is I dont see “Personal” in the Preferences window, only General and Converter - neither of which have anything to do with this type of preference.

Since the password stuff seems to be saved at the module level (I tried deleting the module, trashing it, and re-downloading) seems like its stored by the engine (somehow). This means that resigning from the game wont give the player a chance to re-enter a password.

Any Vassal Devs out there with some insight? Thanks for any help

Will Bauer

This is an indication that you are going into Preferences while only having the main VASSAL module library view open. In order to access the “Personal” tab to see/modify a module password, you must open the module first, then go to File → Preferences.

Yes, your module passwords are stored in a place that isn’t affected by deleting and re-downloading a module. On Windows, this is %HOME%/AppData/Roaming/VASSAL/prefs/, and on MacOS, ~/Library/Application Support/VASSAL/prefs/


Thanks - yes, that was the issue. but it was still a little odd.

When the player opened the module, he next opened a log file I made (with a password on my side) then, before stepping through it, he did the password change in prefs, then stepped through it, then made a subsequent log. He checked and it did seem like the password was saved properly.

When I opened that second log, it still had the null password issue.

He then removed and re-loaded the module, he was prompted for a password for the module, which he provided in the dialog window - he made a new log (just like before) and it worked.

Perhaps he should have made the change after launching the module but before loading a log file?

Anyway, it did work.

Also, I cannot find the prefs file on a mac - if I go to:

mac mini->macintosh HD->library->Application Support I don’t see a Vassal folder at all

Any thoughts on that?

Thanks so much (by the way, I moved out to California years ago, but the fam is in Chanhassen, not far from where you are :slight_smile:


I think the safest course of action is to change one’s module password without having an ongoing game’s file loaded.

That sounds pretty unusual. Removing a module should not touch one’s preferences for that module. It’s the lack of existing preferences for a module that prompts the “Pick your name and password” dialog. I don’t have an explanation here, it’s not behavior I’d expect at all.

Yes, that isn’t the correct location. In the path I specified above, the ~ character expands to one’s home directory. So if my username is Joel, then the fully qualified path is: /Users/Joel/Library/Application Support/VASSAL/prefs

Yes, its hard to sort thru as I wasn’t able to watch exactly what was being done…

as to that prefs file, when I go to users/myName there is no Library sub folder (running MacOs Big Sur 11.5.2) - verified I am running via an admin account

SOLVED: on a mac, you must hold down the option key and use the “go” menu to see that system/hidden folder - got it now and can see the password related stuff = thanks!

If you’re confident doing so, navigating to folders that are normally hidden in the Finder is much faster when using a command line (the Terminal app)–but if you don’t have much experience with Unix operating systems that probably isn’t much help.

My shell stuff is soooo rusty that I try to get around thru the UI if I can.

Makes me wonder, tho: I could delete or textedit the prefs to either change the password or delete entirely to force a new password?

Also, where does Vassal record the password (I guess its “secret name”) associated with a side in a log file? If you changed passwords between 2 log files, does it get confused about that? There isn’t any doc that I find about the internal structure of the log file - but I haven’t pulled the OS source down from git either :slight_smile:

Sure. Every module preferences file is plain text. Like I said above, delete one prefs file entirely and the next time you run that module, you’ll be prompted to pick a new name and password.

Passwords locking defined player sides are in logfiles, but not in any readable text fashion. If you change your module password in an ongoing game, you’ll lose access to the side you previously occupied (and would be unable to claim it, as it would remain locked by your old password if you didn’t vacate the player side). Whether or not that hampers your ability to proceed depends on what aspects of the module are side-specific (player hands, private windows, masking, restricted access pieces, etc).

Thinking there must be a way to view/debug log files - wonder how Vassal devs do that? There must be a model of its structure and a way to view it (?)

Meanwhile, thanks Joel for the help - I’ve learned a fair amount this week!