Ambush Mod will not load map Vassal 3 - !!!Fix Found!!!

This mod stopped working when the new vassal came out. Specifically, When starting a new game, the prompt to pick a map board does not come up. So no maps can be loaded. Otherwise, It looks like everything else is fine.

Can some one take a look at the Mod and see if changes need to be made to get it working. As far as I can tell everything looks normal, and it worked with ver 2.9.9.

I was able to fix it and get it working in 3.0.13 by editing the mod and
resetting the mapboard prompt to ‘Pick board’ as well as clicking on and
opening the properties for each actual mapboard but not change anything
(image etc.) then resave the mod

However, I have no idea why this worked and think this has some obscure bug
buried in it there somewhere - a dev would have to take a look at that -
almost like some sort of file chooser cant find the specific image since
upgrading so it just passes over mapboard selection when running

Post generated using Mail2Forum (

Follow up for devs:

The third mapboard named ‘delete’ would seem to be root of problem.

It is a blank map with a vassal hex grid with file named ‘untitled.gif’

‘untitled.gif’ is not anywhere to be found inside the actual module itself and generally in 3.x blank maps default to file ‘null’ - was this the case with earlier Vassal?

Deleting this map from the mod also fixed the problem, but I suspect it was supposed to be in the mod as it did have a proper map name given to it (even if it was called delete :slight_smile: )

Thanks Tim. That worked for me too. Going in to the properties under map boards and changing the default board setup from Select board to a map and then back, and then saving the Module is what did it for me.

I loaded the Vassal engine for the first time and found myself at 3.0.17. I had the same problem with the Ambush module and found this thread. I loaded the Vassal engine and clicked on “Edit module”. I scanned all the options, but could not find a way to set the mapboard prompt to “Pick board”. I would appreciate it if someone could provide more detailed instructions. Thanks, Derek


Open the ‘Map Window’ component, then double click on the ‘Map Boards’ component to open the properties window. Click on the ‘Select Default Board Setup’ button to bring up the board picker, then click Cancel to Cancel the Board Picker, Ok to close the ‘Map Boards’, then save the module.


Brent Easton
University of Western Sydney

Messages mailing list …

Post generated using Mail2Forum (


I know this is an old post but just had the same problem and was able to fix it using a combination of the above solutions so thought I’d post here exactly what I did for people like me that have no idea about editing vassal modules!!!
Its basically what the previous poster said EXCEPT at the point of selecting the default board you actually choose a board and then un-choose it as ‘thecleaner’ said in his post.

Here is the process it looks long but it’s easy just follow step by step;

Run Vassal.
Click File
Choose Edit module.
In the pop up window select the ‘Ambush.vmod’ file located in your modules folder within the vassal program folder.
In the VASSAL Module Editor window click the key type symbol beside ‘Playing Surface [Map Window]’ entry to expand this directory.
Double click the [Map Boards] entry to open the properties window.
Click on the ‘Select Default Board Setup’ button to bring up the board picker.
Select Map A (or B) from the drop down ‘Select board’ field.
Click OK to close pop up.
Click OK to close ‘Map Boards’ pop up.
Double click the [Map Boards] entry to open the properties window.
Click on the ‘Select Default Board Setup’ button to bring up the board picker.
DO NOT Select a map.
Click OK to close pop up
Click OK to close ‘Map Boards’ pop up.
Click File.
Choose Save.
Click ‘X’ in top right hand corner to close editor.
Now when you start Ambush module you can click the ‘NEXT’ button to choose your map A or B.


Thanks for the fix, it works good.

I do have a question, though. The module page lists the various gamettes, but the only thing showing up in the module is the original Ambush game. Am I missing something or is this all that’s been completed?

My appreciation to the builder, I love this game.