Anything change for Game Piece Inventory Windows since 3.5.7

I’m having trouble with Game Piece Inventory Window that’s getting placed on the main toolbar in Vassal 3.6.7. I’m pretty sure what the problem is, but I don’t know how to fix it.

I’m upgrading the BSG game to work with Vassal 3.6+. I made sure the settings match the settings that are in the GPIW settings in the previous version, and I made sure that the “Inventory can see into Private Windows not accesible to current players” is set to always. I’ve also made to that all the pieces that should show up in the inventory window have a marker with Property Name of “Type”, and a value of what type of card it is.

Even though the code works and displays everything how it should in Vassal 3.5.7, all it does is load a blank window in 3.6.7. I’m attaching two links to screenshots to this. The first link is how the inventory window should look. The second link is the settings for the inventory window in 3.6.7, taken directly from 3.5.7. I believe the issue is with the “show only pieces matching this property” because it fails the expression builder in both version, but somehow still works in 3.5.7. Anyone have any suggestion on how I fix this?

Situation window:

That’s a weird expression yes, and I’m kind of amazed it actually ever worked. Try {CurrentMap.startsWith("Player")} (including the braces) instead.

1 Like

That seems to have fixed it. You are amazing, and thank you.

1 Like