Artifact left after I exit Ancients

When I quit a game of Command and Colors: Ancients I have an artifact left on the screen. This artifact is the top of the game board from the tool bar down to the second row of hexes. This artifact does not respond to any commands and to clear it I have to reboot the computer. I checked to see if it was my CPU causing the artifact by loading older versions of the module. I found that they all worked except for v4.2.6 and v4.3.1 (the two newest versions of the module). I also reloaded the newest version of Vassal (3.6.19) and that did not fix the problem.

Is anyone else having this problem? If no one else is having this problem then my guess is that I have a glitch in my CPU and will just have to live with it. None of the other game (modules) that I have tried have this problem (Fighting Formations, Stalingrad '42, Combat Commander, Tank Duel, GBACW, and others).


Would you post a screenshot of this? I’m having trouble visualizing what you’re talking about.

Just finished a game on line and after we ended the game this is what I had left over. The HoverSnap is what I used to make the screen image and it is working ok. I can not do anything with the Vassal artifact for Ancients except move it around the screen by grabbing the top bar. None of the other buttons or controls work.

Hmm. Looks like the application is still running, or at least has failed to close completely. What action did you take to end the online game? Did you close the play window, or just close the smaller Module Library window?

Can you display a list of currently running programs through the task manager? Can you end the task through the Task manager?

1 Like

30 minutes later…


Agreed, something is hanging. Might be some info in the errorlog, but it looks like the Module Manager has already closed which might be part of the problem.

Vassal will be in the Task Manager as 'OpenJDK Platform binary, something like this:

Lets see if this helps Brent.

When I start the game the task manager shows ‘OpenJDKPlatform binary’ task.
I can end that task and the artifact goes away.

If I am in the game and want to end it there are several ways for me to do this.
If I go to the module and open the file menu then select Quit from the file menu then everything shuts down as it should.
If I select Close (X in the upper right corner of the game window) everything shuts down as it should.
If I go to the module window and select Close Game from the file menu then it does ‘not’ shut down as it should, the ‘OpenJDKPlatform binary’ is still showing in the Task Manager, and I am left with the artifact that I sent you a screen shot of. I can select, in task manager, ‘OpenJDKPlatform binary’ at this point and End Task and the task ends and the artifact goes away.

As I said I have not had any problem with any other game modules in Vassal and I do not have this issue in Command and Colors: Ancient modules before the two newest versions. I am also running Vassal 3.6.19 and Windows 10 Home with an Intel(R) Core™ i7-7700K CPU @ 4.20GHz 4.20 GHz. My System type is a 64-bit operating system, x64-based processor.

I hope this helps.


Close Game should not close the program. Close Game closes the active game, but does not close the Player.

1 Like

I agree that it should not close the program. The problem is that once I use the close game I can not do anything else with the module window. I can not start a new C&C: Ancients game or open a saved game file or use any of the buttons on the tool bar or close the window. I will close the game using the ways that work from now on.

It would be helpful to see an errorLog from a run where you have this problem.

See here for instructions on where to find your errorLog.