Avalon Hill Tobruk module

Downloaded module and everything seems to work except I can’t set up a scenario. Right click, left click, alt-click, ctl-click, nothing seems to work to get a unit onto the map. Does anyone know the secret to actually putting units on the map to play a scenario?

Using Vassal 3.4.5 and the Tobruk 1.1 vmod file I had no trouble placing units on the map. Click the units dialogue on the top,
select the unit you want and drag it onto the map … Hope that’s clear.

I’m using 3.4.6 - module doesn’t work

I’ve tried Tobruk 1.0 and 1.1 - same result. Click on unit but can’t drag it anywhere. Module doesn’t work with Vassal 3.4.6

I think I might have the answer to your problem. The German and British untis are built with an access restriction.
German/Italian units can only be moved by German or Solo player, British units can only be moved by the British or Solo player.

I suspect that you started the game as observer. In that case you cannot move any counter.

That’s it exactly! Thank you!