B-17 bug

I received this today concerning the B-17 module I have been upgrading.

Neil from Australia wrote me this:
“The module you are trying to use (C:\Games\VASSAL B-17 QotS\B-17_QotS-v2.5.vmod) was created with VASSAL 3.2.0-beta1. This version of VASSAL (3.1.19) cannot edit or play modules which are that new.”

Any solution?

-Craig

I would interpret that to mean that Vassal 3.1.19 cannot open modules that were written or edited in the 3.2.0 beta. You will need to download the 3.2.0 beta in order to open that module, or ask for a version that is compatible with 3.1.

Cheers,
Seth

In my experience - but I might be wrong - if you edit a module with 3.2.0 even just to add/modify a 3.1 trait (i.e. not using any special new 3.2.0 functionality) and then you save it… then it won’t open again on 3.1.18/9. It’s the tiling thing that gets you.

Very annoying if you didn’t save a backup version. Unless there is a way to remove the tiling outside Vassal?

Thus spake Craig68x:

I received this today concerning the B-17 module I have been upgrading.

Neil from Australia wrote me this:
"The module you are trying to use (C:\Games\VASSAL B-17
QotS\B-17_QotS-v2.5.vmod) was created with VASSAL 3.2.0-beta1. This
version of VASSAL (3.1.19) cannot edit or play modules which are that
new."

Any solution?

Don’t load the module with anything older than 3.2.0-beta1.


J.

Thus spake barbanera:

In my experience - but I might be wrong - if you edit a module with
3.2.0 even just to add/modify a 3.1 trait (i.e. not using any special
new 3.2.0 functionality) and then you save it… then it won’t open again
on 3.1.18/9. It’s the tiling thing that gets you.

Very annoying if you didn’t save a backup version. Unless there is a way
to remove the tiling outside Vassal?

This is incorrect. It has nothing whatsoever to do with tiling. There
is simply a check to prevent modules created in 3.x from opening (and
potentially working incorrectly) in 3.y, where x > y.


J.

So… if with 3.2.0 I do a simple edit on a 3.1 compliant module - like for example modify the module name from FOO to BAR - then it won’t work anymore on 3.1.X?

Sounds a bit extreme…

Thus spake barbanera:

So… if with 3.2.0 I do a simple edit on a 3.1 compliant module - like
for example modify the module name from FOO to BAR - then it won’t work
anymore on 3.1.X?

Exactly.

Sounds a bit extreme…

It’s not. The alternative would be writing a great deal of code to
detect incompatible changes. That would be a huge effort for very little
gain. When we moved from 2.9 to 3.0 and from 3.0 to 3.1, it didn’t take
long in each case for the older version to fall out of use.


J.

I got the same message and so I upgraded to VASSAL 3.2.0 beta1 and I was able to open it with no problem. I had 3.2 on my machine for a few days and had edited a few modules to change the name that appeared in the list until I discovered that VASL and VSQL will not work yet with 3.2. When I deleted 3.2 and reinstalled 3.19 I couldn’t open the modules that I had modified. I deleted them and edited them with 3.19 and deleted B-17 and installed the module that works with 3.19 and everything works the way it is supposed to.

I now feel much more familiar with VASSAL.

Just as an aside, it is generally not necessary to remove old versions of Vassal when installing the new ones. I have…many, and they all play together nicely.

Well, I’m not sure what to tell those 2 guys who emailed about this issue. The reason I posted this was Neil stated he did’t want to take the leap into 3.2. So I said: okay, let me see what I can do. Well, I have yet to find a solution other than telling him he needs to take that leap. I like 3.2 bc now I can play that mega-map from SPI called The Next War.