BSG module issue

Hi everyone, just wanted to start by saying I’m new here so apologies if this has already been posted before.

Anyway, I’ve downloaded Vassal to play the module Battlestar Galactica Board game module and when I attempt to open the module I get the error - Defunct Custom Code. No idea how to solve this as every version of the boardgame results in me getting the same error? Is this just because it’s not updated?

Is there a resolution for this, or does the module no longer work?

Thanks in advance for the help :slight_smile:

Surprisingly I worked out this module works with Vassal 3.5.8 :thinking:

The module needs to be updated for use with 3.6.

Have you tried contacting the module’s maintainer about updating it? If you’re logged in, you’ll see the maintainer’s email address on the module’s page.

Yeah I think your right. Thank you for the advice, I’ll send them an email notification :slight_smile:

I came here to talk about the same thing. The full error is:

Removed classes, methods, and fields in C:\Battlestar_Galactica_FFG_4.5.vmod
(used by => removed item, version when removed => VASSAL.Info.compareVersions(java.lang.String, java.lang.String), 3.6.0 =>, 3.6.0 =>, 3.6.0

I was hoping it was something simple so I could just go in and fix it myself, but I know very little about Vassal/Java programming.

The cause of the problem and the solution for it are here:

It doesn’t require any programming to fix the problem, only deleting some files which should never have been in the module to begin with.

However, if someone is going to fix the 4.5 module, the fixed version MUST have a new version number. My understanding is that there have already been quite a few newer versions of this module which haven’t been uploaded, and one also MUST NOT duplicate any of those version numbers. I don’t have a complete list of the version numbers already used. Do you?

Given that, is it worth repairing the 4.5 module when there’s a much newer version that could be uploaded?

So, in the couple of weeks since I commented on here, I’ve been able to remove the problem code, and replace it with something 3.6.6 likes so it will run the module. BSG has now been upgraded to 4.7, and it works with the newest Vassal. The new modules are up on the module page.