Bug Report: Map Shading not toggling correctly since at least 3.7.6

OS: Windows 10
Memory: 16GB
VASSAL: 3.7.6 - 3.7.8
Module: Empire of the Sun 5.10.3 and 5.1.1, BCS Arracourt 1.05

I have a found a bug with the current Map Shading properties. Basically if you turn on map shading and leave it on after finishing a log or saving a game file the shading will stay “stuck”. If you turn OFF the shading before finising the log or saving the game then the shading will work properly.

I have created some sample logs both in BCS and Empire of the Sun. I suggest the BCS logs because it’s individual unit map shading that toggles on and off and the problem should be MUCH easier to uncover than in Empire of the Sun where I employed property values and scripts to synchronize units on the map turning on their shading all at once or turning it off (and to complicate matters I also added exclusion properties for out of supply units…)

This bug is NOT present in 3.6.19, I do not know yet if versions 3.7.0 thru 3.7.5 also have the bug. I’ll start checking later this evening when I have more time. I can also confirm that loading a “stuck” game file (log or save) in version 3.6.19 doesn’t pose a problem. You can turn off shading in that VASSAL version and then go back to your regularly upgraded version of VASSAL.

Let me know what other information I can provide and where to send the sample logs.

If you could provide a link to the Arracourt log demonstrating the problem and the exact steps to reproduce the problem (assume I know nothing about how your module works).

Narrowing down exactly which Vassal version the problem starts would be a bonus, but I suspect it will be in all 3.7 versions.


I’ll share via OneDrive. To be clear Arracourt isn’t mine but it’s the easiest way to demonstrate the problem.

Load this log in VASSAL 3.7.8: BCS_Arracourt_Solo_5.1_3_7_8.vlog

That’s the arracourt module run in VASSAL 3.7.8. Proceed to run through the log until the very end. It will turn on green shading zones for 4 game pieces. Once the log is complete, go to any piece that has the green shading zone, right click and select the first option that says “Show Screen Range” it should turn OFF but it doesn’t. It’s stuck.

Now load this log in VASSAL 3.6.19 BCS_Arracourt_Solo_5.1_3_6_19.vlog

That’s the same module but running through a log created by VASSAL 3.6.19. Proceed to run through the log and it will execute the same steps. Turning on the screen range for 4 units. Once you’re done, proceed to right-click on one of the units with a green shading zone and cliclk “Show Screen Range”. This time the shading will turn off.

1 Like

I believe I have found the problem. A feature was added in 3.7 that allows Area of Effect traits to be just locally visible, not to other players. The conversion of AoE traits had a bug so that traits that where already on pre-3.7 ended up both on and off in 3.7.

I have uploaded a test build VASSAL-3.8.0-SNAPSHOT-e4c0985-13153-aoe-migration at Builds of vassalengine/vassal

Could you please install this and try the fix?

I tried this fix but it doesn’t really work. I used BCS again and tried the following scenarios:

  • Loaded the old 3.7.8 log with active area effect showing.
  • Created a new log under 3.8.0 and leave units with an area effect showing
  • Created a save file under 3.8.0 and leave units with an area effect showing.

In all cases after I closed and I loaded the log/save, the area effect would not work correctly without doing the following:

  1. Toggle the active units area effect so as to turn it off (although the shading remains)
  2. Refresh the counters.

Note that simply refreshing the counters as step 1 does NOT work. You have to toggle the area of effect first and then refresh to effectively turn the shading off. Only after that do you get the expected behavior. But as soon as you leave an area of effect on (whether in a log or save file) you’re stuck again.

Hope this helps.



Hi, I can’t reproduce your results, the new version I supplied works perfectly for me with your supplied log and save file. Can you please confirm that you used this exact version (For Win64):


and not one of the other 3.8.0 snapshot builds?