Bug? Terraforming Mars maps are missing with Vassal 3.6.4

I just installed Vassal 3.6.4 and now when I open the Terraforming Mars module (version C2.1.0) the maps are missing. Using the Wizard, the list of maps to select from is empty. When I try to open the module with the extension (TfM_Colonies_1.0.vmdx) activated, I get the following messages in the log:

  • Terraforming Mars version C2.1.0
  • Unable to load extension TfM_Colonies_1.0.vmdx: Could not find Tharsis-Orange in Map Boards
  • Deactivating extension TfM_Colonies_1.0.vmdx

I am running Vassal on Windows 11.

1 Like

I can replicate this, but for whatever reason hitting “Next” to skip past the first Select Board picker (which as you indicate is empty) brings up a second Select Board picker that is populated with choices. From there things seem to load and work OK.

1 Like

So I was taking a peek at the module with the editor and I noticed 2 Map Boards items (see image) under the Main Map [Map Window] which might explain the 2 selectors appearing in the wizard. One Map Board is empty and the second one contains the actual boards. Checking the Main Map under vassal 3.5.8, the first empty Map Board is not there; so is it something 3.6.x is adding if it can’t find one as the first thing in Main Map?

2 Likes

Thanks for the report,

Yes, 3.6.x is adding a default ‘Map Boards’ item if the Map Boards items has been moved further down.

Thanks for the report.

1 Like

Due to changes in the way At-start stacks and Decks are handled, the BoardPicker component (‘Map Boards’) needs to be defined above and At-start stacks and Decks.

I’ll probably handled this via a Validator that will complain when you try and save the module where you have moved the BoardPicker down below a Stack/Deck.

3 Likes

I’ll update the module and move the Map Boards component to the top.

1 Like

There’s a build going up now (BoardPickerBeforeStacks) that warns of the double [Map Boards] and when Decks or Stacks are created before the Map Boards. I can’t stop the new [Map Boards] being created, but this should make it clear how to fix it straight away. Would appreciate it if you could reproduce the issue and give this a try.

Regards.

I was able to find the build on the GitHub site and get it installed. Your validator appears to be working; I got a warning from the editor when I tried to save the module with the Map Boards in the wrong place and when I tried to save with multiple Map Boards.

The fix has been merged; it will go out in 3.6.5 when that’s released.

1 Like

Terraforming Mars version C2.1.15 & Colonies version 1.06 have been uploaded and are awaiting approval. This could possibly take a few days, so please be patient.