Bug: Turn Counter displays List items that are supposed to be hidden

I have a Turn Counter with a single List on it. On the List properties, the ‘Allow players to hide items in this list’ box is checked.

When the game is run and I configure the List, the first item in the list gets unchecked and should now be hidden. But that first item still appears when moving forward (clicking ‘+’) through the list but notably not when moving backwards (clicking ‘-’).

Conversely, if I uncheck the last item in the list, it is not displayed when moving forward but does display when moving backwards.

Any lines in the middle that I want hidden, work as expected.

Encountered this issue first in 3.7.8; went back and found it in 3.6.19 as well.


Ok, so your saying there is no Vassal version you know where this works as you expect?

Correct. I tried the “allow to hide” feature for the first time with V3.7.8. I tried it with v3.6.19 (which is the other version that I still have installed) to see if it worked there.


1 Like