Bug: unwanted map button (similar to GPIW button but no workaround)

I’ve stumbled into a map variant of the GPIW persistent button bug reported in @panther_2010’s thread here.

This time, the Toolbar Menu workaround doesn’t work.


Define two map windows (I presume one will do just as well) without button image.
Define a tool bar menu including the button names for the map windows (button image and text null)
Define an action button for the hotkey that will show/hide the map(s)

The action button and hotkey work but the micro-button shows no matter what.

Seems that only one button appears in the example module, even though two maps are defined in this way shown above. It will show a default tooltip if the tooltip is blank.

Download here.
Open the module, join a side.
Select new setup. No need to set up any maps. Finish.

This toolbar should appear:

Private Window is an action button that sends a Hotkey (Escape key) that will show/hide a unique private window for the side.

Next to it is a spurious button for one of the map windows. It will have the same effect. Depending on side joined, you may or may not be able to press it. Note the default tooltip text.

Note: The maps are configured with null image and tooltip. Map button names are configured into Menu Toolbar that has null button image and text, so might be expected not to display in the toolbar.

We can’t reproduce this in 3.6.0-beta2.

Oh man, beat me to the punch! Yeah I think “something we fixed in 3.6” must have fixed this.

I do kind of wonder what. But I’m not necessarily curious enough to spend a lot of effort to “look the gift horse in the mouth” :slight_smile:

Thanks both for looking into this… yes, now I try with v3.6.0-beta2, it does indeed seem fixed.

For v3.5.8, the workaround is to either put up with the small button or just be satisfied with a Toolbar Menu offering the map options.