Can't Create an HTML Help File

Vassal 3.5.5 - Windows 10

I’ve never tried to install an HTML help file before and I must be doing something wrong as it won’t work.

I have a simple HTML page with a small css file to define width and it has a few small images in a folder called “Images”.

In the editor, I go to [Help Menu] and “Add HTML Help File”, and I add the following information:

I click OK, the game pauses as if it’s doing something and then goes back to the editor with the new entry in place

If I look at the properties for the new HTML Help File, it shows Contents as null.

If I save the module, close it, re-open it, start a new game and select the HTML help file, nothing happens.

What am I doing wrong?

Thus spake DrNostromo:

I’ve never tried to install an HTML help file before and I must be doing
something wrong as it won’t work.

You have a colon in the filename, which is illegal on Windows.


I click the Select button, browse to the folder where the files are and click OK. That’s what it puts in the box. I didn’t change anything.

Also C:(directory) is a perfectly normal path in Windows.

So, I don’t quite understand what you’re saying

If I can’t include a proper path to the files, how do I get them?

As a side note, I’ve converted the HTML files to PDF and was able to include the help file that way and they work fine. I’m still just curious on how to include HTML file in there.

That’s a path, not a filename.

I’m getting this from the automatic bug report it looks like was yours: … i?id=14407

That’s part of my point.

When you click the Select button, it doesn’t allow you to select a file. All it allows you to do is browse and select a folder where the files are located. You can’t select an individual file using that button and you can’t edit it manually.

The bug report was from the first time I attempted to enter an HTML file. I never got any error messages after that, but I still couldn’t get one installed.

I think I figured out why the error occurred. It’s not from a filename …it’s from the original Menu Command that I entered.

I was thinking about this and it occurred to me that I originally entered the Menu Command - How to Use Vassal: Sleuth.

In later attempts, I removed the colon. Thinking this may be the issue, I just went back and tested this and I found that if a “:” is used in the Menu Command, it produces the same bug report I got last time.