Can't run any versions past 3.6.16

When I try to run any version newer than 3.6.16 (3.6.17+) it never completes or opens and an exception is logged in my event viewer of:
Exception code: 0xc0000005
This looks to be coming from mscvrt.
I updated all my visual++ redistributables but no satisfaction. Any ideas what might have changed in 17 that I need resolve in my OS? This is on Windows 10 BTW.

How far along does it get? Is this when opening the Module Manager, or a module?

Never gets open at all, no GUI

I’ve tried via the shortcut and by doubleclicking a module, same result in both cases

Check the errorLog immediately after trying to launch Vassal. What do you see there?

Would you also give a bit more description of what you’re seeing in this event viewer? What is the event viewer? What’s it showing? A screenshot would be useful.

Here is a screens shot and the exported text. I’ll reinstall .17 to get a vassal error log:

Log Name: Application
Source: Application Error
Date: 11-Jun-23 17:45:04
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Faulting application name: VASSAL.exe, version:, time stamp: 0x6445161e
Faulting module name: msvcrt.dll, version: 7.0.19041.546, time stamp: 0x7f567a50
Exception code: 0xc0000005
Fault offset: 0x00086870
Faulting process id: 0x111c
Faulting application start time: 0x01d99cadfa9fa8e0
Faulting application path: C:\Program Files\VASSAL-3.6.17\VASSAL.exe
Faulting module path: C:\WINDOWS\System32\msvcrt.dll
Report Id: 68a2ba6b-9130-40fa-8c5e-eda4ff9d3493
Faulting package full name:
Faulting package-relative application ID:
Event Xml:




C:\Program Files\VASSAL-3.6.17\VASSAL.exe

And it looks like that it doesn’t even get far enough to start a log, I have a log file for every version I’ve used except 17

The launcher isn’t reaching the point where it starts Java. We upgraded Launch4j, the package that creates the launcher, from 3.14 to 3.50 between Vassal 3.6.16 and 3.6.17.

This is the only report of this problem we’ve had, which makes me suspect something is wrong on your system, rather than generally.

If you replace VASSAL.exe from 3.6.17 with the one from 3.6.16, are you able to launch 3.6.17?

Yes I am able to launch 3.6.17 with the 3.6.16 vassal.exe

I wouldn’t be surprised if something is up with my system, I just wasn’t sure what it was since old versions worked. This is a work laptop and we have some GPOs that lock down certain aspects of Java, so if something new was introduced that is locked by us, that would explain it.

The problem has nothing to do with Java, so far as I can see.

It’s probably a bug in Launch4j introduced between 3.14 and 3.50 which requires circumstances most people don’t have. If you’re willing to test a series of builds, we could track down at what point the change was introduced. If we don’t do this, it’s unlikely the problem will ever be solved. Up to you. How would you like to proceed?

I’m happy to contribute! Let me know what I need to do!

1 Like

Ok. I’ll upload a substitute VASSAL.exe for you to try in a bit.

1 Like

First one to try:

Put this where VASSAL.exe is in your 3.6.17 install and try running it.

What I need to know is what the result of that is—either that it fails (and it would be interesting to know what the failure looks like in that case if it’s not the same as previous failures) or that it launches Vassal successfully.

We’re probably going to go through a half dozen iterations to find what changed.

That one loaded correctly

1 Like

Next one:

That one failed immediately. Event Log:

Next one:

Another fail:

I have to go AFK for a few hours, but will try the next one you put up soon.

Next one: