Carcassonne copy & edit existing expansion fails


I try to create an extension with just one extra tile in it.
Almost everyting works by copying the cathars expansion and editing the copies accordingly.
When starting Carcassonne the extension loads, and I can select my new expansion, but Cathars expansion is loaded also automatically, without selecting it.

I copy/edit 4 times:
toplevel (add the cathars)
game piece prototype defenitions (tile_cr)
setup window (add_cr)
setup window>box(deck) (for this I unzipped the extension file, created a map ‘images’ and put in it my new .png tiile and rezipped)

I’m missing something somewhere but just can’t find it


Sounds like you need to deactivate the old extension. In the Module Manager, right-click the extension and pick Deactivate.

I can’t. The real-life Cathars expansion exists in the .vmod. I’m trying to make an extension of a fan-made expansion, using the cathars expansion inside the vmod as an example.

Just made a second extension, selecting one of the two new extensions makes them both active.

I think I’m not entirely clear on what you’re trying to do. If you’re trying to create an extension (.vdmx file), why are you unzipping extension files and the adding in new images? Is there some reason you wouldn’t use the extension editor to just add the new tile image to a deck in the vmod?

If the Cathars expansion is inside the vmod, there’s no way to suppress loading it by adding an extension. Extensions can’t affect the base components inside a vmod file.

I create a .vdmx file, and put the .png files into an images folder inside the .vdmx because I don’t want those images inside the vmod with ‘official’ expansions.
And almost everyting works, the new extension loads when I start Carcassonne, the newly created expansion is selectable between the already available expansions (like cathars) only when I select that new expansion, it automaticaly starts the expansion I used as an example also. So there’s somewhere a link I forget to cut but can’t find it.
I already tried inns & cathedrals to copy/paste/edit my expansion in, but with the same result: iinnes & cathedrals is also loaded.


Had to give unique global hotkey to my newly added expansion. Is there a list somewhere inside a vmod and/or vdmx of already used key combinations?

Thx, I’ll be back as soon as I try to add new meeples :smiley: