Combat Commander Pacific - Why won't ordinance fire? Bug?


I’m playing CC:P using Vassal 3.1.12 on Win XP, solitaire. Sometimes, when I activate a howitzer, it’s fire function to hit numbers are greyed out. I’ve tried using the remove weapon lock feature, that doesn’t solve the problem. I’m playing a fire order from my hand, activating the team and the howitzer, and then going to the fire functions menu. In both range 2-9 and range 10-16 (this is a US Pack Howitzer, but it’s happened with a Japanese Battalion Gun as well) all the choices are greyed out. I can’t find any reason in the rules why I can’t fire the gun (it’s unbroken, it’s equipped by a team that is unbroken, both the team and the gun are activated). I’ve tried first selecting a defending target and also not doing that first, nothing. It’s easy to work around, but I’d like to figure out what I’m doing wrong if that’s it, or if it’s a bug in the module. It’s the American turn, this isn’t op fire.

This scenario is Ichiki Attacks, but as I said the same thing happened with a Japanese gun in another scenario (#1 I believe).

Thanks for any help,