Combined Application Window & 3.5.x

I rolled out a release of a module to a tester once 3.5.2 corrected Map Flare/Does Not Stack.

The issue is the ‘Combined Application Window’ which I don’t use. The prepared Pre-defined setups work but only if this option is left unchecked. This also applies when “New Game” is selected.

The Main Map does not have a show/hide toolbar entry. It does not spawn.

The Main Map only shows when a show/hide button is added and then selected. At that point, the Main Map spawns but remains detached from the Menu/Chat window as does the Game Piece Palette. I was expecting both to attach the chat window and present ‘dividers’ to allow resizing.

Again, with the Combined Application Window left uncheck - everything works. Every window type (private/chart/piece palette/etc.) present along with the Main Map (automatically) as expected. With the Combined Application Window “checked” - every window spawns exactly the same way except for the Main Map which won’t until it’s button is selected.

I tried removing the “prefs” file for this module to reset all preferences but to no avail.

At worst, I’ll release with a note stating that the “Combined application window” setting should be ‘unchecked’.

Windows 10 platform.

The module in question is … .vmod?dl=0

The Main Map doesn’t display when combined application window is enabled. I’ve tried moving the map window within the module, clearing tile cache, deleting “prefs” for this module…

This is a work in progress and only the first 12 scenarios are done.

This issue has been resolved and involved a simple reordering of elements within the module. Moving [Global Options] and [Global Properties] to the top allowed the Main Map to present itself.

Thanks to cemoreno for the guidance.