Delete reporting broken in recent Vassal versions

I’m sure the issue’s a bit different than that, but that’s what I’ve got at the moment.

I’ve been going crazy trying to get a new module, with some fancy footwork, to properly report delete actions. I just noticed that an old module, where it worked, now has the same problem…

The Federation & Empire module (available through a link provided on the module page in the wiki) reports most actions taken. When deleting a unit, it reports something like “* DN deleted in 0902”. In 3.2.13 this turns into “* DN deleted in”, with the location missing. Other reports, such as creation, moving and cloning work fine.

Going through my personal collection of Vassal installers shows this cropped up between 3.2.6 (where it works) and 3.2.7 (where it doesn’t).

I believe this is related to the fix for bug 10211. Can you verify what location property is being used in your Report Action traits?

The original module uses $oldLocation$, but I tried a few other things while flailing around.

This appears to still be a problem for me. Even with 3.2.13. $location$ is always blank for a delete report action which I assume is the expected result. However $oldLocation$ is wrong. By that I mean. If the piece has never moved it’s blank. Otherwise oldLocation reports the location previous to where it was deleted from.

I’ll post what I’m seeing here (this is an existing module written by others that I have been modifying).

Here’s the Module

Here’s a log showing the issue

I’d appreciate any help I can get.

Here’s most of the log for those that would rather not download it. The report action is on the Marker prototype.

[code] - the report action is set to show $oldLocation$
- Let’s just delete a PC Marker to start

  • Royalist PC Marker removed at
    - No location listed
    - now lets move one first before we delete it
  • Royalist PC Marker moves from Corbridge to Carlisle
  • Royalist PC Marker removed at Corbridge
    - Notice how it lists the original location. Now where it was deleted from.
    - Let’s move one 2 spaces
  • Royalist PC Marker moves from Durham to Kendal
  • Royalist PC Marker moves from Kendal to Egremont
  • Royalist PC Marker removed at Kendal
    - As you can see oldLocation is one space behind[/code]

Would you create a minimal example module showing the problem?

Here you go.

  1. Start module
  2. Start game
  3. Put a piece on the board
  4. Move piece
  5. Delete piece

Any chance of seeing this worked on?

I just did some fiddling around, and I can’t find any variable that will cause proper reporting on delete. Everything else is fine, like reporting a clone, or even having that variable display in a text label. But a delete action reports one step behind.

Thus spake Rindis:

Any chance of seeing this worked on?

I’m not working on VASSAL at all until we’ve moved to our new house.
(End of January?) I’ll have a look at the test case then, but if the
solution turns out to be complicated, be prepared for me to say that
I won’t work on a fix for it in 3.2. I intend to spend all of my
development time in the new year on VASSAL 4.


new house? wait after all that work! Damn! ok scoop plz (offline) or at least say im in black :slight_smile:

Thus spake Tim M:

new house? wait after all that work! Damn! ok scoop plz (offline) or at
least say im in black :slight_smile:

The new house is the one I’ve been working on all this time.