Dice result in the chat is delay in some occasions

I design a module and when I play with other players througth the server the reult of the dice is delay. When you press the dice roll button (Symbolic) the result don’t show in the window chat. When you press a second time the chat show the 2 results in good order and correctly… it is hapen allwais, odd time you press the Dice button the result is shoy in the symbolic button, but delay in the chat window. Even button press show both results.

If you move the chat up and down with windows lateral scroll you can see the resul, but it is not show automatic mode.

When I not conected to the server the delay don’t happen.

Apart from the not happening offline, this sounds like the problem of an unterminated html “<“.

If you are using html (enabled in global options), check your module for use of < or > in report outputs. Use the equivalent html special character strings instead i.e. &lt; and &gt;. Also, check any html to make sure it is properly formatted with no missing < or >.

Mark, thanks for your answer.
I see the Dice and only see this symbols in the Report Format:

*** <$playerName$> *** $name$ = [$result1$,$result2$] = [$numericalTotal$]

I have inlcude more symbols < or >?

Thanks in advance.

I have not write Html code… my progam skills in vassal are very poor… You can see…
Other idea I can check???

It sounds like you haven’t enabled html chat in Global Options. In which case, I don’t think you have the problem I mentioned.

I suggest that you provide a small module to demo the problem.

I have check it and it works.
Now the die rolls show perfectly in the chat screen.

@marktb1961 thanks for your help!
I will ask you more doubts!

@marktb1961 I test module again and really the problem continue…
all work perfect, but when you select a side, ‘Observer’ include, the problem start.
Odd rolls don’t show in the chat window and when press roll again, both result are showed.
I have select Global Options HTML Allways.

Some other idea for solve it?

You need to change this:

to this: *** &lt;$playerName$&gt; *** $name$ = [$result1$,$result2$] = [$numericalTotal$]
(and anywhere else there’s a literal < or > in your text output, if it’s not an actual HTML tag).

Anything that looks like HTML but isn’t actually valid HTML causes this bug.

As @jrwatts says or, as you are not using HTML in your Report output, you could just set that Global Option to Never.

I see that the problem happen when you open a game and change side after open during the game. If you select in the window open your side and name at start the problem not happen.

We have to try select it at the beginning then there are no problem.
Really this can work always, but I think we can use the module w/o problems.
Thanks @marktb1961 and @jrwatts for your help. If in the future there are solution for this I hope hear it. Thanks

If it’s happening when you change sides, there’s probably a < somewhere in the report for changing sides. Is this module on the wiki or can you share it, so I can take a quick look at it?

I have in the vassal module website:

It is TNB 2.xx (2.10 or 2.11 I am changing some details… ). If you start a game (Files/Play a Game) and switch sides (button with blue and red helmet in front) when open, the problem happen.

Thanks for your time @jrwatts.

I cannot reproduce the error; tried local and online, tried swapping sides multiple times, and the dice rolls always displayed immediately. The only suggestion I have to try is to make sure you Refreshed Predefined Setups in the editor (from the Tools menu) after making your changes.