Dismissed threads still appear among New threads

In the forum, when I “Dismiss” threads from my list of “New” threads, the option to not see them listed again (whatever the exact wording is) does not seem to be working.
In other words, despite clicking the option to stop following a thread, it keeps showing up in my “New” list day after day.

Would you show us some screenshots of what you’re referring to?

It’s too late now, because I’ve now read this thread, but if you reply to this thread I’ll check in a little later and get a screen shot.

In the meantime, to rephrase what I wrote yesterday:
During my daily visit to this website, I click on the Forum icon at the top of the page to read any “Latest” and “New” threads.
If I try to “Dismiss” any “New” threads and try to include the “Stop Tracking…” option in order to no longer be notified of new messages to a particular thread, the option doesn’t work and still get subsequent notification of new messages to the thread.

This may be different from what you’re after, because it looks like a global setting and you may want to be handling this on a topic-by-topic basis, but I’m curious how your Tracking settings are configured currently–and if adjusting them might help a bit (e.g. just disabling it outright):

In short, maybe inverting the behavior might work better–don’t track at all as the base rule, opt-in to tracking when/where you want.

Oh good grief, forgetabboutit.
Worst forum software ever.
I’ll stop complaining now. Thanks for the free software. Seriously.

Ok. I’m happy to look into the problem if you show me what it is. You could still post the screenshots I asked for.

I don’t understand what I did to warrant that reaction. I was genuinely trying to be helpful. Sorry it missed the mark, I guess.

Here is the option that sometimes comes up when I “Dismiss” New comments:

I find that this option doesn’t work, as I’m still shown the threads on subsequent visits. In other words, it doesn’t “Stop tracking”.

What did you click on to get this dialog? I’ve never seen it before.

ROBS - Something to try that will maybe (?) achieve what you want…

CLICK Vassal FORUM icon (colloseum) - Click Categories
Click each category and (for each) click the Bell icon (upper right).
Then select “MUTED”

I want to Dismiss “Unread” threads and never want them to show up again. Here’s another pic that shows the greyed-out background:

In the past, after dismissing threads that I wasn’t interested in and checking the box, the part about the thread never showing up again has not been working, as far as I can tell. I’ll let you know if this particular thread shows up again for me tomorrow (if someone replies to it).

Korval - Thanks, but I don’t want to effect entire categories. I just want to be able to dismiss individual threads as per the popup option.

1 Like

That doesn’t answer my question: What did you click on to get that dialog?

Would you please point me to whatever it was? I can’t even start investigating without that information.

The “Dismiss” button, in the lower right of the screen. The option to dismiss permanently only seems to be given for “Unread” threads.
(Maybe you’re not familiar with this because you’re an admin and always read everything? Odd that you’ve never seen this.)

Could you post a screenshot showing the Dismiss button? I don’t see one anywhere.

Are you joking? Are you reading this on a phone or a proper monitor?

Click on my last posted picture from a couple of days ago, to enlarge it, and look in the lower right side of the greyed-out area, you will see it.
If you’re not getting the option to “Dismiss” threads that you don’t want to read, then I guess we’re using two different types of forum software - seriously.

During my daily routine visiting this site and after clicking on “Forum” at the top menu, I get the option to read various threads, such as “New”, “Unread”, and one other option that I forget. In all cases, I get the option to “Dismiss” any that I don’t want to read. Additionally, with “Unread” threads I also get the option of checking the little box on the “Dismiss” window that pops up that is supposed to remove those threads from ever showing up again, and that is the part that has not been working.

Has anyone else reading this never seen the “Dismiss” button?

Not joking. I had to test a bunch of different combinations of forum preference settings to figure out how you are getting presented with this Dismiss button and others are not.

I’m now willing to bet that if you go to your Preferences → Interface → Default Home Page you currently have it set for “Unread”

I use the setting “Latest” and have never, ever seen this Dismiss button–I assume @uckelman is in the same boat. I changed it to “Unread” and immediately started seeing it, which (if clicked) gives the same popup you’ve been sharing.

1 Like

Indeed, I also have “Default Home Page” set to Latest and have never had it set to anything else.

At no point have I been joking.

I experimented too, with help from your post. I think the Dismiss option also comes up for Default Home Page “New”. I also have it set to Latest, which works best for me.

Here’s a link to the preferences page in question, the Default Home Page dropdown is a few lines down:

1 Like

I don’t recall ever seeing a dismiss button either, FWIW.

I switched my Default Home Page to Unread. What I see is this notice, I believe because I have no unread posts:
Observe the three conditions in the notice. Are the posts you’re unable to dismiss in topics you created, where you replied, or where you read the topic for more than five minutes?

(NB: I split this discussion to its own thread, as it’s not relevant to the “New” site anymore—the current site hasn’t been new in over two years.)