Does Not Stack Bug

I have created a focused .vmod (linked) to demonstrate this bug. All you have to do to recreate the bug is drag a single piece onto the game-board and then click elsewhere to de-select the piece. Then, you will need to use ctrl-click to re-select it for movement as per the traits. But, you will find it does not move, even though it is set to allow “move when selected”.

Thanks for that. Tried the vmod and ran a couple of trials.
config 1: as per your rules. Piece cannot move.
config 2: as per 1 except move normally. Piece can move.
config 3: as for 2 except stack normally. Piece cannot move.
config 4: as for 3 except move if selected. Piece cannot move.
config 5: as for 1 except select using ALT key. Piece can move.
config 6: as for 5 except stack normally. Piece can move.

Enough. The issue is with the use of the CTRL key. Everything works using the ALT key.
As to the why, I’m not a Vassal Engine developer.

Same result for Mac where the equivalent is Cmd+click - that is not working but Shift and Alt click is.

Ctrl/Cmd + click is a new feature and I recall @Cattlesquat put it in.

I have quite a few negative comments from MAC users re the use of the CMD key. They had a workaround, but I’ve forgotten what it was. I think it had something to do with the use of CMD + shift, or is it what you have stated shift + ALT in lieu of just the CMD key?

FYI. I have only used the ALT key to select a piece. I have never had a problem. Change to the ALT key is the best advice I can give. The ctrl key may lead to other issues I have never considered. For windoze, who knows. Not many, if any, windoze keyboard shortcuts use ALT.

That makes sense as a workaround. But, if for some reason the devs think the functionality should remain unfixed then we should probably remove that option from the trait, just so as not to confuse/frustrate those who seek to use it. I’ll standby for guidance from them on the disposition of this post (solved/unsolved).

1 Like

Try pressing Alt+Left-Click in almost any module in Vassal v3.5.8 (at least) or later.

It is the default shortcut for “flare”… can be a bit of a distraction albeit a harmless conflict with its use for selecting a Do Not Stack piece.

On the subject of Mac and Cmd key - in this context I was only talking about Vassal’s (non-working) Mac equivalent to Ctrl as the click modifier key. Unfortunately MacOS reserves Ctrl+Click as a psuedonym for Right-Click (remember the original, single button, Mac mouse, anyone?). I’d be interested to hear the specific issues your Mac users had with the Cmd key.

I reverted to using Shift+Click after finding Alt+Click unsatisfactory. That was before this latest change, which I have yet to try until this thread. Shift then brings in a different conflict - group select, but that is less intrusive that flare.

The flare is nice. We use it often to indicate the hex/spot on the map in question. A minor distraction when it comes to using ALT to select a piece.
MAC users found the CMD key simply did nothing. Unable to even flip. Mind, I have not heard any negative results for a while now. One player in my current is a MAC user and He has not mentioned any issues.
Back to the original question. If the Vassal guys remove the cntrl/cmd part of the do not stack trait (and have a automatic converter for modules that use this) then perhaps the ctrl/cmd key with click can activate the flare. Cntrl/cmd and click moves away from the do not stack ALT that works and removes the flare while doing so.

With apologies I don’t actually understand what bug/problem is being discussed here. “The issue is with the use of the CTRL key” – use of the CTRL key for what? Is CMD key on Mac behaving differently from CTRL key on non-Mac?

Yes, sorry. If you take my original post in isolation, it should be more clear. I’ve provided a focused .vmod for repro and steps in my post. This is a Does Not Stack trait issue. When the piece is set to only select with a ctrl+click and to only move when selected, it doesn’t move. The rest of the comments are ancillary to that. This isn’t urgent for my projects. But, it did come up, so I thought I should report it.

1 Like

Indeed the original post by HaraldFair was about the failure of the ctrl/cmd key being overzealous (!). I just thought to try and isolate the cause, not the root cause, as I know nothing of how to program Vassal. Using the ALT key has no issues that I have found or reported back from other players, MAC or PC.
Is there a potential programming issue the use of the ctrl/cmd key? Probably.
How much to correct the issue versus just removing that option and just stick with the ALT key?
There would need to be some sort of workaround to convert those that use the ctrl/cmd key to the alt key though.
Swings and roundabouts either way. Have fun.

@HaraldFair Gotcha – could you please install (custom install so you can keep your regular version) the build called “FixCtrlDoesNotStack” at this URL Builds of vassalengine/vassal

… and then let me know if I succeeded?

There was one obvious thing that seemed to be missing compared to the flow for the other keys.



Your patch works perfectly. Thank you.
Also, FWIW, I think “Alpha Centauri” was one of the best games ever made. You’re the man!


Great, thx! And glad you liked it, it was fun to make! BR

That build also fixes the Mac variant (Cmd+Click) :slight_smile:

I’ve merged the fix. It will go out in 3.6.7.