Dynamic Property - numeric - min/max values

I suspect this is not a bug, but a feature request… However, given the documentation isn’t clear (to me), I’m going to report it here…

Dynamic Property
numeric = true
min value = 0
max value = {10 - limit}

It appears that max value is expecting only an integer and will not accept a Beanshell expression that resolves to an integer.

Possibly not a bug, but I had a clever way to use this if I could enter a Beanshell expression…

If this is functioning as designed, it would add clarity if the help documentation mentioned that these won’t accept Beanshell expressions…

There’s a few fields like this that don’t accept beanshell. Layer and text offsets (and colors) are other examples.
In general, most fields without the “caculator” icon do not accept beanshell. Exceptions I know of are the text fields in the Text Label and Report Action traits. Also, in the Prompt field of Dynamic & Global Properties if I recall correctly.


I’ve tried using an expression in the prompt area of a DP (Prompt user to select from list). I’ve tried BasicName, $BasicName$, {$BasicName$}, {BasicName}, GetProperty(“BasicName”), the last also with enclosing $ and {}. No joy. I’m guessing that adding an expression to the prompt field of a DP is not possible. However, if it is possible, how to do so?