Error with Twilight Struggle Version 3.1.1

This is my first post on these forums. I am having a consistent problem with the Twilight Struggle module version 3.1.1. I am unable to participate in any online games. When I try to sync with a game, I get an error message that says:

[i] - Bad Data in Module: Liberation Theology [Basic Piece] - Map not found mapId=1 Decks

  • Bad Data in Module: The Voice of America [Basic Piece] - Map not found mapId=1 Main Map
  • Bad Data in Module: OAS Founded* [Basic Piece] - Map not found mapId=1 American Hand[/i]

The actual cards listed in the error change each game, but I always get the error now. Then I am able to place influence as both sides, my cards in hand have no values where their ops values should be, and I am unable to headline a card. The game cannot progress at all.

If I start a game first and then someone tries to join, they are unable to place influence or do anything to initiate the game.

I am running Vassal version 3.2.12. I successfully played 3 games with this set up in the past. Last week I was in the middle of a game with someone else. On turn 7 I played the South America scoring card, but at the end of the round the game ended because it said the card was never played. Ever since then I have had this problem. I have no idea if the problems are related.

I have uninstalled Vassal and deleted the modules multiple times and reinstalled fresh copies from the webpage. I have tried to uninstall and reinstall Java. I am still having the problem. I submitted bug reports with the errors multiple times. Does anyone have any information that can help me?

System Information:
Windows 7 x64
Vassal Version 3.2.11
Twilight Struggle Module 3.1.1
Java version 8 and Java version 6 on my computer (Java 6 was download with a Vassal reinstall after I had uninstalled older copies. It said it needed a JRE and downloaded this)
12 GB memory
Processor: Nvidia 570 (i7, 3.05 GHz)

Could you send me the log file from such a game?

Hi mkiefte,

I am a bit to new to Vassal so I’m not totally sure how to do it correctly. I joined a game to get the error, clicked Begin log and tried to save it, then clicked end log. However the file doesn’t show up anywhere! Also the error that I receive pops up before I am able to begin a log file so I’m not sure if it would be recorded or not.

I am able to see an Error log on the main Vassal screen under Help so I will try to send this to you via PM. I’m not sure if it is helpful or not.

Update: I was able to successfully join a game with someone after they initiated it. This happened when I was trying to duplicate the error. He determined he was running an identical Vassal and TS module as me. This is the first person it has worked with recently, but I am still able to get the error by joining any other game. It still fails 99% of the time.

Thus spake Hetfield72:

I have uninstalled Vassal and deleted the modules multiple times and
reinstalled fresh copies from the webpage. I have tried to uninstall and
reinstall Java.

This is for you and anyone else who comes across this post:

Reinstalling a module, VASSAL, or Java without a specific reason to
suspect that one of them is corrupt is a waste of time and makes it
harder to establish what state things are in when troubleshooting. If
VASSAL runs, it’s unlikely that VASSAL or Java is corrupt. Similarly, if
you can load a module, it’s unlikely that the module is corrupt.


In the previous attempted games where you were getting the error, had you verified before starting that the other person was using the exact same module version as you?

I only ask because I played a couple games online recently and found that the vast majority of the people playing live on VASSAL are still using the older Twilight Struggle module (3.0.11). At one point I asked someone why this would be, and he responded that he doesn’t like the newest one because he perceives all the prompts that come up to be excessive handholding. I don’t share that view at all, but perhaps it explains why so many players persist in using the older module.

Hi Joel,

Thanks for the helpful comment. I actually spent this evening testing your theory and I think you are exactly right! I tried games with 10 different people. It failed with 8 of them, but each of them was using some other type of module. Some claimed, just as you said, that they only play with the old module because of fewer prompts. Others swore they had the newest module, but when I clicked on their profile I saw it wasn’t the case. The 2 games that did work were with others running the exact same module as me.

So in the end it looks like it was just stupidity on my part for not realizing people were using other versions of the module. My advice to anyone that comes across this thread in the future is to not take anyone’s word for it that they have the most up to date module. Right click their name and look at their profile to confirm. This will save you a lot of headaches! My mistake earlier was just taking people’s word for it.

Thanks Joel and everyone for the helpful comments. I really appreciate you taking the time to help out a Vassal newbie :slight_smile:

It appears that this type of behaviour may occur if you attempt to sync the new module with the old version. Some times it crashes and sometimes it doesn’t. If it doesn’t crash then very odd things start happening – basically it attempts to create the game as best it can and then fails. There’s still a number of people playing the older module so this is somewhat problematic.

Basically, if you try to sync with an older version it may still behave oddly even if you try to sync with a new version without exiting the module completely.

The solution is for the VASSAL module to simply exit if you attempt to sync with an older version. This appears to be the simplest thing I can accomplish at the moment as there are a large number of things that would otherwise have to be modified. I’m hoping that the issue will resolve itself as people move over to the new module.