Experiencing extreme lag with Vassal

Hello, I use vassal to play malifaux. The lat few games I have tried to have I have suffered from extreme lag. every click and movement that I take has a lag of 10 to 15 seconds. it makes playing the game impossible.

I am running it on mac OS catalina , I have the latest version of Java installed. I also have the latest vassal and Malifaux module. Any ideas what the issue could be.

its not my internet as that us fibre to the door and I have no issues playing on xbox live that sort of thing.

thanks for any help

You don’t need to have Java installed separately–VASSAL will no longer use system-installed Java anyway, it comes with its own. Although you didn’t specify what CPU your Mac has, this very much sounds like you have a newer Apple Silicon (M1 or M2) processor, so it’s possible you mistakenly installed the MacOS build for Intel CPUs. See this recent thread–if you have an M1 CPU and the correct build installed already, there’s a preference you want to enable if for some reason it wasn’t by default.

Hi thanks for the reply.

that’s good to know about flash.

sorry should have put more information in. its an intel i7 Mac with 16 gigs of ram. So can’t be anything to do with M1

Check the max heap setting for the module. (Look on the General tab in the module’s Preferences). To what is it set?

Hi Thanks for the reply.

Maximum head is set at 512, not sure what this is, what should it be set to?

Try setting it to 1024MB, close the module, and reopen it. Does that make any difference?

thanks for the pointer I tried this out and given it a quick test. seems to be ok. I will see how I get on when I have a proper game