Feature request: Ignore commands while typing in the chat

Hello there.
I bound my + and - keys to zoom in and out respectively.

That works wonder, except if I happen to type a dash or a “+” for whatever reason in the chat window, the command is also triggered and the zoom level shifts.
I think that commands should be ignored when the chat window is selected. I’m unsure whether this could be considered a bug or a feature request so I filed it in here.

Thanks for reading,

1 Like

Probably not exactly what you’re asking for, but you can avoid the problem if you turn off “Use combined application window (requires restart)” in your Preferences for the module (this moves the buttons that respond to “+” and “-” to the [now separate] map window, instead, so their window doesn’t have focus when you’re typing in the chat window). You can also use the numpad “+” and numpad “-”, instead…they register as different keys.

1 Like

Nice idea which I readily adopted for my own purpose. However, sad to report, Numeric Keypad + / - give the same spurious chat passthrough that the OP reports for normal +/-.