For the People module 100% CPU

I have games running under 2.02 version of For the People.
Every time I try to move a counter or splay a stack my CPU goes to 100% for 3-5 seconds and you have to wait or you could end up moving pieces elsewhere. It’s very frustrating.

Any idea on how to solve it?

I have a macOS High Sierra with a 3.2 GHz Intel Core i5 and 8 GB RAM DDR3.

I have the Activity Monitor open when I do this so I am sure it’s the CPU going to 100%.

Possible too many calculated expressions. These can hog the system and slow things way down if there are too many. Mind, 1 CP across many counters/game pieces can add up to too many CPs.

I don’t know about VASSAL CPs.
Would require redoing the modules or changing counter properties or are those scripts?
Its doable or does it require restart from scratch?

I have just fired up that module, started a new game, and tried moving a few pieces about and I can see no indication whatever of the problems you are describing. The module runs very quickly.

Does the same thing happen when you start a new module? or is it just with your saved games?

Do you get the same problem with the latest 3.4 version of the module. I understand that the save games may not be compatible.

Do other players report the same problem?

It may possibly be a problem with the version of Java you have installed.

I’m now with latest VASSAL 3.3.2.
The problem happens with new games and saved games.
It does not happen with FTP 3.4, but I have to complete older games with 2.02.
It I minimize to a very small screen then it goes smoother (still with drag), so it can be something related to graphics.
I have been updating Java with each new release, but of course it could be some Java thing.
Anyway, it seems something related to only my computer.
Maybe allocated RAM? Which should be a good number?

tried upping the VRM to something higher?