Game Piece Inventory Window

What modules are these? I tried all the modules with similar names in the module library, but what I found doesn’t match any of them.

Have you tried removing the Tooltip text? It’s pointless without a visible button, and I’m wondering if its presence is forcing Java to draw something to attach it to…

Interesting… yes, I can reproduce this in a module (under v3.5.8 at least).
Removing the tooltip does not remove the spurious button. In fact, there’s even a dummy blank tooltip - which no other button does!

Possible workaround: Name your GPIW button. Create a Toolbar Menu with a blank name and no image. Add the GPIW to that Toolbar Menu (on its own or with other hidden GPIW buttons).
Seems to work for me.

Update: Just realised that @kerkael made this suggestion a while ago further back in this thread.

I remain unable to reproduce this problem. If anyone wants it worked on, I need a test module which exhibits the problem and also contains an example of a button which is correctly hidden.

Here’s a new module with a hidden GPIW called hidden and a visible one called visible.

I agree that there doesn’t appear to be a bug. Perhaps this example can be used by panther_2010 as a template to get rid of the small square.

1 Like

Ummm…I just opened Benkyo’s test module in VASSAL 3.6.0 Beta 1, and the small square is perfectly visible to the right of the Pieces button (and clicking on it brings up an empty GPIW window). Weird.

I experimented a bit with a new module, and discovered that simply starting a new module, adding a GPIW, clearing the button text, image, and tooltip text, and then starting a game will cause the blank square to appear. Strangely, if I then edit the GPIW (with the game still running) and cancel the edit, the square disappears. Accepting the edit doesn’t change anything. Once I’ve cancelled an edit with those fields blank, the empty box is gone for good, until I close the game and start a new one–then it reappears if there’s no text and image.

Right. I just thought that was intended behaviour and not a bug. You can’t make a button disappear just by removing the label and image, you have to want to hide it by the toolbar menu method.

If it is a bug, my module clearly illustrates it.

1 Like

First of all I have to thank all those who have helped me to solve this age-old problem.
Actually, just removing the Tooltip text, as suggested by jrwatts, does not remove the spurious button.
The solution is, instead, that suggested by marktb1961, Benkio and coinzop, i.e . that of name the GPIW button, create a Toolbar Menu with a blank name and no image and then add the GPIW to that Toolbar Menu. I didn’t know this was possible.
To uckelman : you could not find the modules for the simple fact that they have not yet been uploaded as they are still under development.
Thanks again.

1 Like