Game window starts minimized and board needs to be maximized

I’m on a Macbook Pro with VASSAL 3.2.17
Most of the mods that I’ve downloaded start with the wizard and then jump to the lower left hand side of the screen (minimized). I’m writing a game for kids so the UI has to be easy to use. I have to figure out how to start the game with the top menu maximized and the game board on screen.

There is one mod called Avalon Hill Trivia Game witch dose not have this problems, but I can’t figure out how to adapt it to my game.


I have the same problem on a MacBook Air 2018, with MacOS Mojave (10.14.5) and VASSAL 3.2.17.

I am also experiencing this issue on a MacBook Air 2019 running MacOS Mojave (10.14.6) and VASSAL 3.2.17.

Two modules that suffer from this, for example, are MBT and Panzer.

Would be great to find a fix for this.

I have the same problem.

I have macOS High Sierra 10.13.6 and VASSAL 3.2.17.

VASL (the ASL module) starts up correctly but all the rest I try do not (For the people, OCS, Cataclysm, The peloponnesian war…)

Any news on this bug?

Have you tried Vassal 3.3.2? I think some of the window-divider-in-wrong-place stuff got cleaned up.

That was it. I upgraded to 3.3.2 and this problem seems to be solved.