Heap Size? Upgrade Vassal Now Getting This Pop Up

Hello everyone, names Bobby & i just upgraded my Vassal. I had the very first version & now i just got the newest version today & when i load it up & go to open my SWMinis.mod a pop-up containing this appears:

[b]Maximum Heap Size Too Large

The mazimum heap size stored in your preferences for this module is too large. In particular, the maximum heap size must be less than the amount of physical RAM in your machine. The failsafe initial heap size of 128MB will be used instead. Please decrease the maximum heap size in your Preferences, and restart Vassal [/b]

Now i have no idea what this is.
I found a few threads on this forum about it but nothing that helped me.
I have no clue what my RAM is & i had the first version of vassal & just upgraded to the newest. My SWMinis.mod worked fine before but when i just upgraded to this new Vassal, im getting this pop-up. Please someone if you know what this is help, i appreciate it thank you

Have you tried changing the maximum heap size in the preferences of the module manager?

It sounds like you’re trying to run VASSAL on a machine with very little RAM.

  • M.

On 21 April 2010 19:42, DarthPercocet <messages@forums.vassalengine.org (messages@forums.vassalengine.org)> wrote:

Post generated using Mail2Forum (mail2forum.com)

I have the same problem and get the same message. I have 512 MB memory, which may be archaic by today’s standards but should be enough to run VASSAL, I would think. Even if I manually set the preferences to 128 MB, I still get the same message. Also, when I try to open any map file larger than a few MB, I get the following message:

VASSAL has run out of memory. This module requires more memory than the maximum heap size you have set for it. Please increase the maximum heap size in your Preferences, and restart VASSAL.

Windows Task Manager says java is using 169 MB and VASSAL is using 84 MB. Is it some setting I need to adjust in java?

Glen G.

Thus spake “GlenG”:

Whether you have enough memory depends entirely on the module you’re trying
to load. In order to load a several MB image file, it might take a few
hundred MB RAM, because the file is compressed while the representation
of the image in memory is not. You also have to take into account that your
OS is using some of your RAM, and possibly other programs as well.

Using VASSAL 3.1, 512MB is not going to be enough RAM for many modules.
In the future, you might have more success with that amount of RAM, as we’re
going to be loading large map images differently in the next version of


Messages mailing list
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)