Help! Map not showing up any more

I’ve got several PBEM games going and I’m working on a module (my first) so I’ve been in VASSAL quite a bit lately. I sent out PBEM files last night then spent a large part of today editing my module as I slowly figure how to do things. I bounced in and out of VASSAL while editing as I was loading other modules to see how they do things. At some point during this my map went away. I finally figured out that I could start a game and click the “map” button and it would come back but it was now detached from the toolbar and record log area. Kind of odd but things worked so I figured if I couldn’t fix it I’d post here in a day or two.

Later I went to load PBEM files and found that the map doesn’t show up. This is true for Ogre and Hammer of the Scots, but not for Making of the President. For that one the map is there but the record area used to show up only when I opened the piece palette, now it’s there all the time.

I’ve uninstalled & reinstalled then uninstalled and downloaded a fresh copy and reinstalled, then went looking for how to clear the Java cache (I’m on OSX 10.5.2 with Java 5) but none of that worked. I even through in a reboot cause that always worked with Windoze.

Has any one got any any ideas on what this might be? If you’ve got good instructions on clearing the Java cache that might help too. I when throught the Java Preferences panel and removed VASSAL so I think that’s it but it indicated that was web related so maybe there’s something else I need to clear.


When I did the first download and reinstall I didn’t delete the files in /Users/Dave/VASSAL. I went back and did again but this time I cleared out those files and the stuff in VASSSAL and after a re-install everything seems to be OK.

If someone knows what in /Users/Dave/VASSAL might have been messed up please share. It might be useful info if this happens again.

Reinstalling VASSAL/Java isn’t going to help here. Perhaps you renamed the Map Window while editing the module? That could cause the map to be empty. Also, the first Map Window will dock into the main controls window. Others will have a toolbar button to show/hide them. Maybe you changed the relative position of the Map Windows and didn’t specify an icon/label for the toolbar button.


Post generated using Mail2Forum (

This has been a while but re-installing VASSAL after deleting it did bring the map back though it’s now in a floating window.

I’ll have to check when I get home to make sure I don’t have a second map. There should only be one but maybe I added one just to look at something.

On a semi-related note, I’m finding some general oddness that seems similar. My pieces pallet went away in the interface and only came back when I added a new pallet and cut the tabs and pasted them to the new pallet. At that point I had a new “pieces2” button (that worked) and deleted the old one.