Hex Grid - 1st column cut off

Vassal 3.7.5; WIN64.

I’m playing around with coding a new module that will use a simple hex grid. However, strangely the first column is cut off. I tried adding horizontal padding, but that doesn’t solve the problem (just shifts the grid to right).


Adjust the offsets in the Hex Grid to control where the grid starts within the board or zone. Or use the arrow keys in the hex grid visual editor.

1 Like

The editor is flakey. Be patient. I went through 30-odd identically sized maps recently and even copying a working hex grid across them all still required attention to some of them. No rhyme or reason to it. The Horizontal numbering in the Grid Numbering editor doesn’t stick. It also doesn’t seem to matter. Always double check that the half hexes on the edges report what you need them to report (eg 0 or 1). It’s the left edge that was always an issue for me.

Once you do get it work - it stays that way. Let that be of some consolation to you…

1 Like

Brent - thanks, that worked. However, I have a few feature suggestions for the Hex Grid feature.

  1. Would like the ability to be able to separately define the span of the hex grid from the board size. Currently, it just draws the grid in the entire board.

  2. Add check-box to suppress defining/drawing partial hexes, when drawing in entire map board. The partial hexes both look untidy and for most games, would be considered unplayable.

  3. Would like the ability to specify size of grid in hexes (e.g., 9 hexes wide, 12 hexes high) as alternative to drawing in entire map board.

1 Like

What you describe is exactly how it is designed, In most war games, half-hexes are playable.

If you don’t want the grid to cover the entire board, then create a Zone that defines the part of the board you want the grid to be defined/designed in, and define the grid within the zone, not the board.

1 Like

Yep, I know games that use half hexes and those that don’t. I think it would be good if V4 gave the option to keep or suppress partial hexes.


I’ve mostly worked around the limitations, but came across the following additional bug. I wanted to define “fake” at-start-stacks w/ shading to grey out unplayable hexes. See below:


However, in doing so, I came across the bug that my at-start-stack in a partial hex isn’t working properly… (note - I’m using the same definition for all the unplayable greyed out hexes).

See hex: 0310


Most games that I have ever seen that use hex grids have the grids already printed on them, so you don’t actually enable the Vassal grid, so this hasn’t really come up before.

The V3 solution is to use a Zone which limits the reach of an enclosed grid, making it part of the architecture of the map/board/grid system. I suspect V4 will use some similar construct rather than adding size parameters to the grid itself, which seems a bit counter-intuitive.

However, in doing so, I came across the bug that my at-start-stack in a partial hex isn’t working properly… (note - I’m using the same definition for all the unplayable greyed out hexes).

Sorry, it’s not clear what the actual bug is from your description?

I am trying to grey out (using at-start-stack w/ area of effect shading) all unplayable hexes on the map.

This works fine for “whole” hexes, but is failing for partial hexes.

Or in other words, the area of effect shading fails in partial hexes.

Let me know if you want me to upload to my google drive for you to look at.

Is this where there the center of the hex to be greyed out is off the edge of the Map? What happens if you place a ‘real’ shade counter there? I suspect the same will happen? I think it is an AoE issue.

It’s the same issue that AoE shade disappears when the generating counter is scrolled off the map.

Try using a Map Shader rather that having the AoE generate it’s own shade.

Not sure I fully understand your reply. I think you are saying the problem may be that the “center” of the partial hex isn’t on the map, which is causing it to fail. I can adjust size to test it…

Weird, as I adjust the Map Board Size (slowly), the grid display doesn’t change gradually (incrementing 5 pixels at a time)… It either displays a half-hex (which doesn’t show the shading) or a full hex, which does show the shading…

I need different colors for different things…

Sorry, should have been clearer.

I meant to try using a Map Shader to generate the shade. It is generated in a completely different way and may allow you to work around the limitation.


Two comments on this one, including a different use case:
a) In this case, I’m implementing a game which has a fairly simple blank hex grid, so it’s not worth scanning in the map.

b) However, the far more interesting (and new) use case is using Vassal to design a new game, from scratch. In this case, being able to easily & flexibly use Vassal grid (hopefully w/ some V4 enhancements - like ability to suppress partial hexes) allows easy game design prototyping way before any printed components are available.

I have a (hopefully interesting) game design idea, I plan to fully prototype in Vassal. Since, I don’t really intend to market it, just play w/ friends, it will likely never be physically implemented.


Brent - this worked (thanks much!) and shaded a “partial” hex, with the following interesting effect. Before using the Map Shader, I had a partial hex displayed on the map. After using it, the (formerly partial) hex was now shaded, BUT also now showed as a FULL hex on the map.

This allows me to work around the limitation.

However, I still consider the fact that the Area of Effect shader (when used by itself, without Map Shader) will NOT shade a partial hex, to be a bug that should be fixed.

Hmm - apparently I spoke too soon. It worked for a “partial” hex that was showing about 70% on the map and failed for others showing ~50%.

Have you also included the addition of the Zone to limit the size of the grid? I think this is the missing link you are looking for to easily control the size of the grid displayed.

No, unfortunately, because I’m not using a scanned in map image, there is no easy way (that I’m aware of) to define the span of a zone before I define the Grid.

If I could draw the zone on top of the grid, I could do it easily… But the reverse, not so much…

It shouldn’t really matter. Just draw a suitable sized zone on the map where you want the grid to be and fit the grid to the zone, don’t try and fit the zone to the grid. You can adjust the size of the Zone later (and position of the grid) if you need to make adjustments.