Hiding cards when placing & global options

I want to automatically hide cards when placing on a special location. This works already works using a trigger action.
My next step is to add a global option to enable/disable this feature. This is done via a checkbox preference.
Then I changed the trigger property to:

{(Obscured == false) && (hiddenCards)}

and it stops working even if hiddenCards has been selected in the preferences.
What is the correct statement?

Thanks

What is the value of hiddenCards supposed to be? True? False?

You are not telling it in the expression. A checkbox has to be one or the
other

-----Original Message-----
From: messages-bounces@vassalengine.org
[mailto:messages-bounces@vassalengine.org] On Behalf Of Jonas-
Sent: Wednesday, March 06, 2013 5:23 AM
To: messages@vassalengine.org
Subject: [messages] [Technical Support & Bugs] Hiding cards when placing &
global options

I want to automatically hide cards when placing on a special location.
This works already works using a trigger action.
My next step is to add a global option to enable/disable this feature.
This is done via a checkbox preference.
Then I changed the trigger property to:

Code:
{(Obscured == false) && (hiddenCards)}

and it stops working even if hiddenCards has been selected in the
preferences.
What is the correct statement?

Thanks


Read this topic online here:
https://forum.vassalengine.org/t/hiding-cards-when-placing-global-options/5782/1

Thanks for your reply.
I thought I’ve tested it, but seems like I made an error in the statement at that time.
Using

{(Obscured == false) && (hiddenCards == true)}

works.
Is there any documentation on the scripting language since some behaviour like the evaluation of boolean values is a little different to that what I’m used to be.

The most complete documentation to date would be the designers guide. check the properties section

http://www.vassalengine.org/mediawiki/images/b/b0/Vassal_3.1_designerguide.pdf