High Frontier: Bad Data in Module

Hi, new guy, here. Some friends and I played High Frontier while they were visiting and we loved it, but we live across the country from one another and it’s hard finding other people who are willing to play a game that complex. Then we found VASSAL.

So I loaded the most up to date High Frontier module and the supporting files, and got it running, but I keep getting this error when I first start the tutorial:

  • Bad Data in Module: Could not find map Intersteller Map
  • Bad Data in Module: Image not found ESA VP Marker
  • Bad Data in Module: Image not found NASA VP Marker
  • Bad Data in Module: Image not found PRC VP Marker
  • Bad Data in Module: Image not found SHMZ VP Marker
  • Bad Data in Module: Image not found UN VP Marker

I run a Mac, and the modules I loaded are:

HFv4.vmod 2.6.1
HFv4.vmdx 2.6.0
HFv5_Pieces.vmdx 2.6.1
HFv4_Cards.vmdx 2.6.0
HFv4_VP4.vmdx 4.0.2
HFv5_z_HiddenAgendas.vmdx 0.5

And, indeed, when I open the VP window it’s empty. I don’t know what the Interstellar Map is, but it doesn’t sound interesting.

There are other errors about the tutorial being saved with different (earlier) extension file versions, so I suspect that may be whole issue. Am I right, or is this something else?

I tried just starting a new game, and I get the same errors. But now there is a diagram in the VP window, though I think some counters are missing.

You’re exactly right–it sounds like the tutorial was created in an earlier version of the module. All of the image filenames it expects to find are hard-coded into the file, so if the module has changed significantly since, it will complain about images it can’t find (they either no longer exist or go by different names in the current module).

I downloaded the modules and extension files, several times.

The module opens only the map, no pieced, no cards, etc.

It seems the files located here are not usable.

Everything works fine for me. It’s not sufficient to just download the extensions, they also need to be registered with the base module from the VASSAL module manager–it isn’t clear to me that you did this, but it sounds as though you did not. Once the base module has been opened at least once, you need to right-click “High Frontier v4” in the module manager and choose “Add Extension…”, then navigate to where you saved the extension files. Do this 4 times (once for each of the extensions marked as Required on the module page), and you should end up with this in your VASSAL module manager view:


Thanks much for responding.

After “attaching” the extensions as you instructed, the module is now complete and working.

Sometimes the internet is like magic.

Thanks again.