Incorrect Password Doesn't Warn

I was playing a game with invisibility and private boards a couple weeks ago. We saved our progress. Two weeks later we attempted to continue our game. My opponent had changed his password for another game he was using during the pause in our play. When we resumed, he joined the game and Vassal correctly placed him in the side he was previously on, but his invisible pieces were missing from the board. Also, his private board was inaccessible and grayed-out. There was no warning from Vassal that his password had failed. So, we had a long troubleshooting process of trial and error. Eventually, we determined that the password must have changed and was the source of the problem. A simple chat-window warning would have saved us substantial time and frustration.

On what basis did you determine the part I bolded above? It doesn’t square with not seeing his invisible pieces, not being able to access his private board, nor any of my long years of diagnosing and solving player side access issues.

How do you propose VASSAL would distinguish between a player who legitimately belongs in the game but has a different password than before and a previously uninvolved player who isn’t meant to be assigned a side at all?

1 Like

During testing, both he and I found that with a wrong password, Vassal will place you in your previously established side without asking. Once you arrive, you will not have access to invisible pieces nor private boards.
I propose that Vassal continue to recognize the user by whatever means it uses currently, username I presume, place him on the side previously established…and…here’s the new part…put a message in the chat window if the password doesn’t match…pretty simple.

You’re coming to the wrong conclusion…Vassal doesn’t remember user names at all, it only identifies players by password; if you join with a different password, you’re a new player, as far as Vassal is concerned, and it’s giving you a side that isn’t claimed…<observer> in most cases.


This is inconsistent with my experience testing (tonight). Vassal places me in a side, my previous side, and … doesn’t give me the option to retire at all. That button is gone from the toolbar.

As Joel says, how do you know it’s placing on your previous side, especially if the retire button is gone? I’m pretty sure it’s placing you on the default <observer> side, and, because there are no remaining available sides, that’s why you get no retire button.


Observer is not a player side, but the state of not occupying a player side at all.

As a simple example, if I’m playing a module that has only 2 defined player sides and I’ve been going along from the start with my module password set to dog and my opponent has his password set to cat, then I go and change my module password to duck, the next time I load my saved game, I will instantly be assigned observer status without any notice or dialog boxes or opportunity to do anything about it–because my password now fails to match any of the passwords locking the player sides.

VASSAL saved games and logfiles do contain the user names of players occupying sides, but it only assigns to sides on the basis of the password, not the combination of the user name and password.

This is the way it’s always worked (not that it’s a good system, but that’s a different thread).

1 Like

In your test where you assert that you are in your player side yet cannot access private boards/pieces, can you type this into the chat log and report back what it returns:

/property show PlayerSide

1 Like

If that doesn’t work (feature is heavily restricted), once in your game, try (a) typing in chat - module may show it there or (b) changing side … current side is reported in the change side panel - example below.

1 Like

I went back and tested this again…thinking “OK, it’s possible I am the observer and just don’t realize it”. So, I tried typing in chat because “retiring” to another side isn’t available. When I type text in the chat window I get <<>> as my side…whereas normally, when I join as the “observer” I get “<>”. I suppose it’s still possible that I am the “observer”…but that’s what I get.

If it’s well-understood that Vassal uses only the password and therefore can’t throw an error, then I guess there’s no point in taking this further.

Not sure if you mean “normally” as compared to the specific module currently at issue, or just generally across modules in general, but at any rate, the formatting with which player names/sides report in the chat log can vary, because it’s a per-module global option set by the creator.

In this case, we are talking about in the same module, tested back to back. I can create a new game and join as the “observer”. Typing in the chat window will show “”. But, joining into a game with the wrong password for either side doesn’t announce which side is being joined, “retire” button is disabled, and entering text in the chat window shows “<>” as the side entering text…not “”.