Install help please

Hello I’ve had Vassal before a few years back, but am just trying to install it on a Mac running Catalina. I fear I am now too old for all of this.

I have the .dmg file in my downloads folder. When I hit that a window opens telling me to drag the vassal icon to the applications folder to install.

There is now a VASSAL icon on my desktop (a drive type icon, not a vassal icon) which I have dragged into applications. Nothing occurs. If I click on it, it merely reopens the window telling me to drag the icon into applications. I have also tried dragging the .dmg straight from downloads. Same result.

I have no idea what it wants. Can anyone assist please?



This drive type icon is the way MacOS presents an installer, as a virtual hard drive. Do not drag this or the dmg file to the Applications folder. Instead, double-click on the drive icon. You will get the installer window that you saw when you originally double-clicked the .dmg file.

What you need to drag is the Vassal icon in the left of the above shown window. You can drag it to the actual Applications folder or, easier, follow the hint and drag it to the Application folder in the window

If you’re doing an update then there will be one further prompt, warning you about the existing Vassal application file:

Hit “Replace” unless you intend running both old and new versions of Vassal (usually only for those testing out new versions).

That’s Vassal installed. However, to run it for the first time, you’ll need to get past the MacOS malware gatekeeper. This Apple article tells you what to do. In my experience, opening the app the first time just gets you the option to delete the app. Cancel that and repeat the instructions. Once opened, the Vassal app is now registered and can be opened normally in future. You have to repeat this anytime you re-install Vassal.

Let us know how you get on.

Ah thank you. Now you’ve said that it does seem familiar. A case of clear instructions still being derailed by user error.

Much obliged


1 Like