Issues with VASSAL not starting

Are you running some antivirus software? We’ve had some reports of AV software swiping files VASSAL needs to run.

In particular, please check the jre\bin directory under the directory in which VASSAL is installed. Do you see files called javaw and java there? (Or, if your file browser isn’t hiding extensions for known file types, javaw.exe and java.exe?) If those files are missing it means that your anti-virus software has blocked or quarantined the bundled Java JVM that VASSAL uses to run. Open your Anti-Virus program and white list those files.

Beginning with VASSAL 3.3.0, Java is “bundled” with VASSAL on Windows and Mac (not on Linux). This means that on those platforms it no longer matters what version of VASSAL you have installed - indeed you don’t have to separately install Java any more on Windows and Mac. However, some antivirus software does not trust the Java JVM executables which we provide. Thus it must be told to allow them.

Another possible cause if Vassal worked before but has stopped opening is that you have a corrupted global preferences file. Look for the file prefs/V_Global (the prefs directory is in the same directory as the Error Logs) , move it somewhere else, and try to start Vassal.

Perhaps a bit unlikely, but check whether your firewall is blocking the loopback device. The loopback device is a network interface which has your computer as both the sender and receiver. Typically, on IPv4 networks, the loopback device has address Personal firewalls are sometimes overzealous about blocking access to the loopback device, despite that permitting access to it is completely harmless. VASSAL uses the loopback device for communication between its parts. If your firewall is blocking the loopback device, set it to permit access to it.